1

We are using CiviCRM on an existing Joomla site. We first installed CiviCRM and installed afterwards the (localization) language files.

But when selecting an other language then the default US-EN, the system almost hangs. In the resource monitor we can see that the I/O read/write hits the seeling and almost runs out of resources. It happens on the CiviCRM Admin page and also on the front-end pages where we use CiviCRM.

The strange thing is that it worked fine the first time, right after installing the localization files. But some day's later the system became slower and eventually almost hanged. We also tried a clean install of CiviCRM with localization files, but it gave the same problems.

When switching back to the US-EN language it works fine again.

We tried it in both single and multi-language modus.

We use(d) and tried:

CiviCRM 4.7.25 and 4.7.27 whith the corresponding localization files.

Joomla! 3.8.1

PHP5.6 / PHP 7.0 and PHP 7.1 with memory_limit 512MB

MariaDB 10.0.29

Apache libmysql - mysqlnd 5.0.11-dev

Can this be a bug specific to our kind of installation on Joomla/environment? Of do we do something wrong here?

  • With the Joomla debug console I can see that loading the com_civicrm component with the default US-EN language takes a max. amount of 11MB memory and about 300ms to load. When using an other language it uses 25MB memory and about 27790ms to load. – Vincent Nov 15 '17 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.