1

I have searched for answers and none apply to this particular instance. I get one particular error preventing me from installing CiviCRM in WordPress. I have the latest version of CiviCRM and WordPress. I get the following error under file permissions no matter what I do:

Is the /home/tackletheagenda/public_html/Civicrm/wp-content/plugins/files folder writeable?

The user account used by your web-server - tackletheagenda - needs to be granted write access to the following directory in order to configure the CiviCRM settings file: //home/tackletheagenda/public_html/Civicrm/wp-content/plugins/files

I have already verified that the folders were writable. A bug? Other people had this problem on other platforms, but no answers for this problem in WordPress.

  • It seems there may be a problem with the path of your civicrm installation. My working civicrm installation in Wordpress is in the equivalent of your account at /public_html/wp-content/plugins/civicrm. In that directory, there should be a properly configured file called civicrm.settings.php. There should also be a directory called "files" in /wp-content/plugins which should have been created during the installation. – peterb Nov 9 '17 at 18:32
  • Full installation info is at this link wiki.civicrm.org/confluence/display/CRMDOC/… and also here at docs.civicrm.org/sysadmin/en/latest/install/wordpress Hope this helps. – peterb Nov 9 '17 at 18:39
0

The link that is supposed to provide a solution for this is broken...on this page:

https://docs.civicrm.org/sysadmin/en/latest/install/wordpress/

If you are on a Windows machine and get the message "The user account used by your web-server needs to be granted write access to the following directory in order to configure the CiviCRM settings file: C:/wp-content/plugins/civicrm/" even after changing directory permission in Explorer, see:

http://forum.civicrm.org/index.php/topic,5056.msg23720.html#msg23720

0

Did you verify the directories were writable by testing using php - or checking the permissions? To definitively confirm this is a civicrm bug perhaps put something similar to the below in a file in your web root then visit it in your browser. (Don't forget to remove the file afterwards) Check if the file was created. If it was then this is a civicrm issue - however if not it is a permissions issue.

<?php
file_put_contents("/home/tackletheagenda/public_html/Civicrm/wp-content/plugins/files/test.txt", 'Test');
?>

If it is a permissions issue double check the permission of the parent directories to make sure the web user has execute access to all parent directories

namei -l  /home/tackletheagenda/public_html/Civicrm/wp-content/plugins/files

Will show you all parent directories up to / along with their permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.