1

I just upgrade my service provider from apache to litespeed webserver and Civicrm stop to work. The error is in a lot of page: Sorry but we are not able to provide this at the moment. We can't load the requested web page. This page requires cookies to be enabled in your browser settings. Please check this setting and enable cookies (if they are not enabled). Then try again. If this error persists, contact the site administrator for assistance.<br /><br />Gli amministratori del sito: Questo errore può indicare che gli utenti accedono a questa pagina utilizzando un dominio o URL diverso da quello configurato dall' URL di base. ESEMPIO: URL di base è http://example.org, ma alcuni utenti l'accesso alla pagina tramite http://www.example.org o un alias di dominio come http://myotherexample.org.<br /><br />tipo di errore: Impossibile trovare una chiave di sessione valido.

That is seems related to the url base configuration, but it is the same of before and it worked perfectly. I had a similar problem when used Varnish cache that solved removing that cache. But now the pages are no cached with litespeed. I cannnot also configure the backend in order to set civicrm in debug mode. Have any suggestion in order to check if the problem is related to litespeed?

Example page of error: http://www.grag.org/civicrm/?page=CiviCRM&q=civicrm/profile/create&gid=16&reset=1

Here is a hint of the problem: if I use a demo site: http://wpmaster.demo.civicrm.org/wp-login.php (user demo/demo) and then the link http://wpmaster.demo.civicrm.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fmember%2Fsearch&reset=1 using the search button I have in the query string the following http://wpmaster.demo.civicrm.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fmember%2Fsearch&_qf_Search_display=true&qfKey=6709b858d58d2f669a89cae4c9d06171_4657

but on my site after the http://www.grag.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fmember%2Fsearch&reset=1 pressing the searrch button I have the following link and the error http://www.grag.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fmember%2Fsearch the variables is missing.

Now it is solved thank to the service provider that modified the server configuration

  • Your link works. – Christia Nov 14 '17 at 23:59
  • You may want to go through the troubleshooting steps for when you make a major change to the server or change servers which includes clearing caches and deleting certain cached files. Take a look at steps 7 and 12. Don't follow all the steps, just look at those two. – Christia Nov 15 '17 at 0:01
  • The link work, but is you try to add a new mail (you can use a fake mail such as aaa@bbb.cc) there is the error – pk825 Nov 15 '17 at 14:15
  • I don't modify the wordpress installation, just the web server. However I check the two steps but it seems correct. – pk825 Nov 15 '17 at 14:21
  • i added an email abc@abc.com - i saw no error – petednz - fuzion Nov 15 '17 at 18:58
2

I am using the webhosting service of Rochen, and they use a LiteSpeed Web Server. Civicrm runs inside a Joomla 3.7.5 website quit okay. (The the current Joomla version of 3.8.2 and Civicrm do not work together okay, because there are still several issues due to changes in the Joomla 3.8.* versions.)

So as to your main question: Litespeed can be setup to accommodate Civicrm.

0

Not answering your main question but the question re turning on debug. If you have access to the db ther should be an entry in civicrm_setting for debug_enabled. The value needs to be changed from

s:1:"0";

s:1:"1";

  • I have some problem with the debug, I don't see any information in the page with the error. Have you any suggestion in order to get this data? – pk825 Nov 15 '17 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.