2

I'am running a 4.7.27 civicrm on wp. Strangely, for some reason i still ignore, unauthenticated visitors can't suddenly access the petition form (civicampaign) what is a quite big problem because i am engaged in such important campaign.

After reading documentation, I tried to change the access rights from the page "WordPress Access Control".

For another unknowned reason, the "WordPress Access Control" form looks empty (screenshot) and can't be modified despite the fact that i am admin.

If somebody can help me...

"WordPress Access Control" page

  • Thank you for your answer. Yes i am running CiviCRM Admin Utilities. It was already up to date. I flush the cache, but no way, the problem remain. I observe another strange thing : two "CiviCRM" entry in Wp extension page (screenshot). ![enter image description here](i.stack.imgur.com/BDNRk.png) – Frank Nov 14 '17 at 14:42
  • That doesn't sound right. You should check your plugins folder to see why that's happening. It might explain the problem with the Access Control table. Also, make sure you have the latest CAU 0.3.2, try disabling the "Fix WordPress Access Control form" setting and flush caches again once you're done. – Christian Wach Nov 14 '17 at 17:35
  • @Frank: This doesn't appear to be an answer. If you want to create your own question or edit a question with the extra information please do that instead. – Christia Nov 14 '17 at 23:37
2

Found this while having the same problem. The solution is in the CiviCRM utilities Wordpress plugin - go to the plugin settings and there is a box you can tick to "fix the appearance of the WordPress Access Control form". I did that and the Access Controls came back in Civi. CiviCRM Utiities plugin settings

1

Are you running CiviCRM Admin Utilities? If so, upgrade to the latest version. Also, try flushing CiviCRM's cache - you can do this from the CAU admin page.

  • BTW, those permissions would be unchanged by CAU. That may be a separate question. – Christian Wach Nov 14 '17 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.