0

Trying to send my first e-newsletter with the Mosaico system. However, when I try to submit my mailing I get an error message (see attached) despite the fact I've put an unsubscribe token in the bottom of the mailing.enter image description here

  • Welcome to CiviCRM Stack Exchange. Please edit your question to include which version of the CiviCRM you are using as well as which CMS (Drupal, Joomla, Wordpress). Also, please include any research you've done on the issue and what you've tried and checked. It might also help to include a screenshot of your unsubscribe token. – Christia Nov 14 '17 at 23:38
  • Maisy - it helps the StackExchange system if you can comment on or accept or +1 answers so that these Questions don't just 'hang' for ever. – petednz - fuzion Dec 15 '17 at 2:40
1

Sending of CiviMail requires both the domain.address token and the action.optOutUrl or action.unsubscribeUrl tokens

You can add these in to the bottom of your mailing. Add a text block, add the above tokens, then edit it by clicking on < > (source code) and put a link on to the optOutUrl token with the destination also being the token so it ends up like

<p>{domain.address}</p>
<p><a href="{action.optOutUrl}">{action.optOutUrl}</a></p>

There are some longer instructions here I wrote up yesterday. They may help

0

Did you also put the domain.address token in the email? If not you should try that.

As an alternative (but ptobably not, what you want), you could disabel the check for mandatory token following the link: www.yourdomain.org/civicrm/admin/setting/preferences/mailing?reset=1

0

I have the same issue

You will need to disable the footer (because that is what is giving the error message and I couldn't ever work out a way to make it work) as well as doing what you have already done with putting the tokens into the body of the email

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.