The cron job "Activity processor (Hourly)" has started failing for no apparent reason with the message "Failure, Error message: Process Activities failed" in the job log, although the message coming from cron is "Failed Processing: . Reason: DB Error: syntax error". Neither message is much help.

We are running CiviCRM 4.5.8 under WordPress 4.2.2.

Has anyone experienced this? Where do I start to find and fix the problem?

Thanks, Jim

2 Answers 2


If you turn on debugging (Administer menu > System Settings > Debugging and Error Handling) you should get a more verbose error from cron, which should in turn allow you to troubleshoot - or at least update your question with more info!

  • It's possible your CiviCRM logfile (CiviCRM.something.log in wp-content/plugins/files/) already has a record of the SQL error happening in cron. Commented Jun 1, 2015 at 10:43

I had the same problem. I tried to change the password of an email account, and the problem is solved. In the old password I had a question mark.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.