4

I am using civiCRM on Wordpress. I have configured my SMTP settings correctly as far as I'm aware. The test email sent fine. But when I got to 'Mailings' > 'New Mailing' it says 'initializing...' and stops there. Any ideas on how I can create a new mailing?

When I look at 'Draft and Unscheduled Mailings' I see a bunch of unscheduled mailings that haven't worked.

N.B: I commented out this block after following the advice of this thread: http://forum.civicrm.org/index.php/topic,24242.0.html

I am using Bluehost hosting and mail services. CiviCRM 4.6.2

I have tried everything in this post: http://forum.civicrm.org/index.php/topic,35850

Here's the error I get in the console:

TypeError: CRM.addStrings is not a function        angular.js?r=NBb6p:11655 
    at all.js?r=NBb6p:44
    at Object.forEach (angular.js?r=NBb6p:331)
    at httpSuccess (all.js?r=NBb6p:39)
    at angular.js?r=NBb6p:9408
    at processQueue (angular.js?r=NBb6p:13248)
    at angular.js?r=NBb6p:13264
    at Scope.$get.Scope.$eval (angular.js?r=NBb6p:14466)
    at Scope.$get.Scope.$digest (angular.js?r=NBb6p:14282)
    at Scope.$get.Scope.$apply (angular.js?r=NBb6p:14571)
    at done (angular.js?r=NBb6p:9698)

Thanks for your help

  • I had removed some code from the Common.js file to prevent the unsaved form alert from popping up. It worked on the alert but also stopped the new mailing dialogue from opening! This code: window.onbeforeunload = function() { // if (CRM.utils.initialValueChanged($('form[data-warn-changes=true]:visible'))) { // return ts('You have unsaved changes.'); // } }; – thomas jaunism May 9 '15 at 1:14
  • I have the same error after upgrading from 4.6.0 to 4.6.2 (problem still exists after an upgrade to 4.6.3). Downgrading to 4.6.0 fixes the problem... not that's actually a fix in my case. The WP install (v4.1.5) I have for testing has NO plugins active, apart from CiviCRM, so it's not a JS conflict from a third party plugin. – Frosty Jun 4 '15 at 7:25
3

Sounds like a basic javascript problem. Wordpress plugins are sometimes to blame. See troubleshooting javascript in CiviCRM.

  • Thanks for this. I followed everything on that page to no avail. I've added the console error above. – thomas jaunism May 8 '15 at 0:12
2

I have the same error after upgrading from 4.6.0 to 4.6.2 (problem still exists after an upgrade to 4.6.3). It's an error with paths on IIS loading resources.

FYI this is a duplicate of AngularJS issues with Drupal 7 + CiviCRM

The issue tracker shows that this will be fixed in version 4.6.4: https://issues.civicrm.org/jira/browse/CRM-16499

There's a pull request here, with an interim patch: https://github.com/civicrm/civicrm-core/pull/5863

Confirming this fixed my 4.6.3 install

  • The patch also worked on our IIS install. – pmoz Jun 5 '15 at 12:37
0

This error might relate to HTTPS config of the site.

  • I have CiviCRM sites in Aegir, HTTPS managed also in Aegir, and mailing works.
  • Other sites but same CiviCRM version, are beyond Cloudflare and HTTPS are managed by Cloudflare and Pound, but not Aegir. In this case, I have the same issue with mailing: initialising never ends, but all the other part of CiviCRM is OK. Workaround here to run on plain HTTP, which is hardly acceptable.

CiviCRM version is 5.12.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.