1

After moving my Joomla-based CiviCRM site to a new server that included an upgrade to Joomla 3.8.2 on PHP 7.0 and CiviCRM 4.7.29, CiviVolunteer stopped working. I eventually uninstalled CiviVolunteer and have attempted multiple times to install the latest version (4.7.21-2.2.3). I have tried every relevant suggestion found on the web and here on StackExchange including that from Nicolas at Cividesk involving SQL scripts to clean up left-over garbage in the database. Additionally, I have sifted through the database to remove anything that remotely looked like a potential conflict. The installation failure mode is a blank screen. When I navigate to the previous page, I see many messages like those shown in the Nicolas post. Back Trace information doesn't seem to show anything useful. Any help would be appreciated at this point.

  • Did you upgrade your version of the CiviCRM before or after you migrated your data into it? – Christia Nov 29 '17 at 21:32
  • I tried recovering to a new server in multiple methods until one seemed to work. The old server was PHP5.5, I believe. The new server is PHP 7.0. I installed Joomla 3.82, first. CiviCRM seemed to work when I imported the data from the old site and then installed the newer CiviCRM version. In addition to CiviVolunteer failing, reports throw a database error saying there are mixed data collations. – Mark Jividen Nov 30 '17 at 21:58
  • CiviCRM doesn't support PHP7 last I checked. – Christia Nov 30 '17 at 22:39
1

A blank screen can sometimes mean an error on the server. It doesn't show anything in your logs, but might in the server logs. Usually I have to contact support at the web host to see what they can find out. Sometimes it's something as simple as a file/folder with the wrong user, wrong permission, etc.

1

I was the initial question on this thread. The problem was solved by rolling back from PHP 7.1 to version 5.6. Unfortunately, PHP 5.6 security support is slated to end Dec 31, 2018.

0

I am having the same problem after an upgrade of civi 4.7.27 to 4.7.29 Civimail is no longer functional. I did try the suggestion of changing the Resource URL's back to full path, but that did not help.

I get this error message when going to civi CP Warning: Invalid argument supplied for foreach() in /home//public_html/administrator/components/com_civicrm/civicrm/CRM/Core/BAO/SchemaHandler.php on line 750

I get this from my cron job
Warning: scandir(/cur): failed to open dir: No such file or directory in /home//public_html/administrator/components/com_civicrm/civicrm/CRM/Mailing/MailStore/Maildir.php on line 85

Warning: scandir(): (errno 2): No such file or directory in /home//public_html/administrator/components/com_civicrm/civicrm/CRM/Mailing/MailStore/Maildir.php on line 85

Warning: Invalid argument supplied for foreach() in /home//public_html/administrator/components/com_civicrm/civicrm/CRM/Mailing/MailStore/Maildir.php on line 85

Warning: scandir(/new): failed to open dir: No such file or directory in /home//public_html/administrator/components/com_civicrm/civicrm/CRM/Mailing/MailStore/Maildir.php on line 85

Warning: scandir(): (errno 2): No such file or directory in /home//public_html/administrator/components/com_civicrm/civicrm/CRM/Mailing/MailStore/Maildir.php on line 85

Warning: Invalid argument supplied for foreach() in /home//public_html/administrator/components/com_civicrm/civicrm/CRM/Mailing/MailStore/Maildir.php on line 85

  • I rolled back from civi 4.7.29 to civi 4.7.27 which is quite stable. Will keep an eye on stackexchange for the fix. Hoping also for the regression of "Pay Later". Fingers crossed! – Karen-Ann Dec 28 '17 at 23:21
0

Need to change from mailer to SMTP. You are probably still set at the default Mailer Type: mail() Change it to SMTP, and it is a preferred approach to use "Authentication". From the civicrm menu: Administer, System Settings, Outbound Email.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.