0

I am on Civi 4.7.27 and wordpress 4.9

Our organization has been using civi for the last 6 months without any real problems. A couple weeks ago we upgraded to the latest version of civi. Today I noticed that when ever someone submits a donation they get an error 500 page. The donation still goes through and is recorded in civi, but the donor does not land on the confirmation page, nor do they receive their receipt in email. I tried running "Clean up Cache" and "Reset Paths" that did not help. Does anyone know what could be causing this and how I can resolved it?

Thank you.

ADDED INFO 12/5/17 We are seeing the below errors. This issue is still not resolved. Remember everything was working perfectly until about three weeks ago, when both civi was upgraded to 4.7.27 and wordpress was upgraded to 4.9. These errors are not a result of something we did in attempting to fix it as we have not changed anything at this time. I hope it will give someone an idea of what is going on.

1 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Mail/EmailProcessor.php(104):
   CRM_Core_Error::fatal("No mailboxes have been configured for Email to Activity Processing")

2 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/v3/Job.php(401):
   CRM_Utils_Mail_EmailProcessor::processActivities()

3 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Provider/MagicFunctionProvider.php(89):
   civicrm_api3_job_fetch_activities((Array:1))

4 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(169):
   Civi\API\Provider\MagicFunctionProvider->invoke((Array:9))

5 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(100):
   Civi\API\Kernel->runRequest((Array:7))

6 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/api.php(23):
   Civi\API\Kernel->runSafe("job", "fetch_activities", (Array:1), NULL)

7 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/JobManager.php(145):
   civicrm_api("job", "fetch_activities", (Array:1))

8 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/JobManager.php(79):
   CRM_Core_JobManager->executeJob(Object(CRM_Core_ScheduledJob))

9 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/v3/Job.php(99):
   CRM_Core_JobManager->execute(FALSE)

10 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Provider/MagicFunctionProvider.php(89):
   civicrm_api3_job_execute((Array:2))

11 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(169):
   Civi\API\Provider\MagicFunctionProvider->invoke((Array:9))

12 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(100):
   Civi\API\Kernel->runRequest((Array:7))

13 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/api.php(23):
   Civi\API\Kernel->runSafe("Job", "execute", (Array:2), NULL)

14 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/bin/cli.class.php(113):
   civicrm_api("Job", "execute", (Array:2))

15 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/bin/cli.php(32):
   civicrm_cli->callApi()
1

I don't believe that the error shown in the question is likely to be the one that triggers the error 500 for your registrants. Note that the backtrace shown starts with a CLI entry point civicrm_cli->callApi(), suggesting this has been triggered from system cron on the commandline, while your issue is reported as occurring via the web.

First, find the relevant error log.

If you are seeing error 500s, you need to understand what the fatal error was. This probably involves inspecting your webserver error logfiles. You can find these via the webserver (eg Apache / Nginx / ...) configuration, and you may also find there are separate logfiles for a separate PHP process.

The PHP error logs may be identified via phpinfo() (look for "error_log" setting). Webserver logs you'll need to ask your sysadmin or hosting provider. Bear in mind that a shared hosting provider may be reluctant to give access to logfiles which contain information from other sites, but you will need that information to resolve this issue without guesswork.

There should be a log entry made at the specific time you see the error in the browser. Don't accept any red herrings until you find out what this is, because it's essential to you finding the source of the problem.

If your hosting provider cannot help you track down CiviCRM errors, consider finding one who does: https://civicrm.org/partners

0

When I've run into a 500 error, it's almost always been because of something on the server itself. Sometimes it is an issue with files not being associated with the right user. For instance, I'm usually logged in as root, as that means I can easily switch back and forth between all the accounts on the server. But if I upload anything, I have to remember to set the user and group to the correct one, otherwise it's set to root and then I get errors. That's happened a couple times.

More often than not, it's a server error - sometimes a security rule need to have a task in Civi whitelisted so that it doesn't give the error. I pretty much always have my web host handle that, as they can easily access a lot more logs, settings, etc than I can. Usually they'll either ask you how to recreate it, or if it's something they can't access, they'll have you recreate it right then and then give them your IP address. Then they can more easily locate the problem in the logs.

  • Thank you for your reply. I am still waiting to hear back from my host about that. I have spent the last several hours trouble shooting everything. I am convinced the issue is related to use the options under the "Contribution Amounts" tabs. Because the pages that use the membership settings have no problems, but the contribution amounts do. I am concerned there is a bug in the new upgrade. – fdarn Dec 1 '17 at 5:38
  • We're using 4.7.27 and aren't having any issues with it, but ours is the Drupal one, not WP. Here's the Contribution Amounts tab on our most active donation page: nu-look.net/images/contrib-amts01.JPG nu-look.net/images/contrib-amts02.JPG nu-look.net/images/contrib-amts03.JPG – Jenni Simonis Dec 1 '17 at 6:00
  • My host ran a test on it and they said that it is not recording any errors and asked if our application has error logging. I see some documentation about finding civi's error logs at civicrm/files/configandlog/civicrm*log but when I look for that in my file manager I do not even see a /files/ directory. What are Civi's logs at? – fdarn Dec 1 '17 at 14:59
  • Yea, mine kept saying that and then I ended up being the one to figure it out - our php.ini settings for the site had been overwritten by them somehow to the original settings. So execution time, memory, etc were all WAY too low. Caused problems just like this. I'm not sure where logs are kept in a WP install. I'll go see what I can find for our Drupal one. – Jenni Simonis Dec 2 '17 at 3:19
  • Ok, so if WP is like Drupal... you have a place that you have set up to be your file directory for CiviCRM. For instance, mine is /home/username/public_html/sites/default/files/civicrm. Inside that directory is where our uploads, custom template, configuration files, cache, etc are all held. Inside that directory is another directory called ConfigAndLog. Inside that are a bunch of log files. – Jenni Simonis Dec 2 '17 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.