1

I'm getting a warning for my Wordpress install of CiviCRM, under the title Resource URLs: Make them portable:

Resource URLs may use absolute paths, relative paths, or variables. Absolute paths are more difficult to maintain. To maximize portability, consider using a variable in each URL (eg "[cms.root]" or "[civicrm.files]").

On the Resource URLs page it brings me to, I have the CiviCRM Resource URL as

http:// <path to Wordpress install> /wp-content/plugins/civicrm/civicrm

The others on this page which are populated are Image Uplaod URL

[civicrm.files]persist/contribute

and Extension Resource URL

[civicrm.files]/ext/

But when I try to change CiviCRM Resource URL to

[civicrm.root]/

which is the recommended portable value from the help button near the top, and then save it, the value is not saved, and reverts to the absolute URL above, and the warning persists.

I have installed CiviCRM 4.7.27 on Wordpress 4.9.1.

1

One reason that the value may not change is because it's overridden in civicrm.settings.php. See the Overriding Settings section of the documentation.

An upcoming version of CiviCRM will make overridden settings clearly non-editable, but for now, check civicrm.settings.php.

  • Great, thanks. I might just hide the warning for now so if it'll be fixed soon. – Vshura Dec 3 '17 at 19:33
  • The upcoming version won't fix the warning; it'll just make it clear whether the problem I identified is the one you're having. – Jon G - Megaphone Tech Dec 4 '17 at 1:16
2

Starting in 4.7.26 in order to handle the multiple ways that WordPress can be installed on various hosts, we are determining the correct path and setting both the path to the site (front end) and the path to the backend (wp-admin) in civicrm.settings.php.

The resource url status warning will need to be updated to handle this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.