1

I have a custom text field where the user is allowed to link text with uploaded files via ckeditor (respectively kcfinder). Currently the upload of files does take a very long time. It's not a network issue because the actual request is sent after a few seconds. There seems to be an additional step afterwards, which delays the response for minutes (e.g. for a file with size of 4.7MB):

upload request details

If I upload the file via a standard upload input (non ckeditor) the request is finished in seconds.

Here are some details about the request:

enter image description here

Using CiviCRM 4.7.23 with Drupal 7.56 on CentOS with Plesk, Apache and FastCGI.

I do not have this issue on my local dev machine, only on this server.

What could cause this delay? Are there any relevant CiviCRM or server settings?

UPDATE: After adding some error log calls including the current timestamp I could face down the function, which is causing the delay. It is $img = image::factory($this->imageDriver, $file['tmp_name']); where $this->imageDriver has the value imagick. It seems that the creation of the imagick object is taking way to long (the following image tasks are done quickly). Any idea what could cause this?

After disabling imagick and using gd instead the upload is finished in seconds.

  • Whats the contents of the headers tab? – David Hayes Dec 15 '17 at 17:26
  • @DavidHayes Check my updated question. – Philipp Michael Dec 18 '17 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.