0

I'm on Drupal 7 and CiviCRM 4.6.25. Suddenly, I am no longer able to create or edit a contribution record. If I try to create a contribution record from a contact profile, the triangle spins eternally. If I try to create a contribution record from the menu Contributions > new Contributions, Once I submit the contribution I get a blank page. All I can think of is that I tried to setup the CiviXero extension last week but never got around to finishing the setup. I tried disabling/uninstalling it but that did not help with the problem. The Drupal watchdog is not showing any errors.

  • Is there anything in the CiviCRM log file under sites/default/files/civicrm/ConfigAndLog ? – Aidan Dec 11 '17 at 8:15
  • If you right click on New Contribution and open in new Tab/Page do you get a more useful error message? – petednz - fuzion Dec 11 '17 at 18:08
  • I found error msgs in the PHP error log. The accountsync extension was giving this error: Call to undefined method Civi::settings() I uninstalled accountsync and everything is back to normal. It would be nice to know how to solve this though, as I would like to use the civixero extension – Yossi Dec 11 '17 at 18:59
2

civixero extension is build to use for CiviCRM version >= 4.7 so there might be compatibility issue when installing for 4.6.25 as some function may not be present.

| improve this answer | |
  • That seems inaccurate according to civicrm.org/extensions/civixero – Yossi Dec 26 '17 at 14:50
  • Also the issue was the acountsync extension not civixero – Yossi Dec 26 '17 at 14:51
  • Agreed. The extension page in civicrm.org shows that its compatible with 4.2 and 4.4. However, the link to download the extension points to master branch which holds code for 4.7. You can confirm the version and compatibility by visiting the extension page in civicrm (Administer>> System Settings (or Customize Data and Screens) >> Extensions) and click on arrow besides 'Account Sync'. – Pradeep Nayak Dec 27 '17 at 5:03
  • Here is the fix for your problem github.com/eileenmcnaughton/nz.co.fuzion.accountsync/pull/33 – Pradeep Nayak Dec 27 '17 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.