On Civi 4.7.27 and Wordpress 4.9.1

On the contribution pages, if I have Membership section enabled AND Contribution Amounts section enabled, everything works fine. If I have just Membership section enabled, everything work fine. However, if I have just the Contribution Amounts section enabled, after submitting the contribution, users will land on an error 500 page. The contribution will be completed and the record will be stored in civi, but the confirmation email will not be sent.

After hours of trouble shooting I have narrowed it down to: this only happens when the Contribution Amounts section is enabled by itself. Everything was working fine, until the recent upgrades. The error logs I can find are not giving me any useful information.

Also I just installed the same version of Civi on another server and everything works fine, including the Contribution Amounts section. All the settings are the same on both pages. Both Servers are on the same host, so I don't think it is a hosting problem. I think there is something broken is civi, but I don't know how to find out where to look.
Does anyone have any ideas?

Thank you.

Errors from Logs

1 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Mail/EmailProcessor.php(104): CRM_Core_Error::fatal("No mailboxes have been configured for Email to Activity Processing")

2 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/v3/Job.php(401): CRM_Utils_Mail_EmailProcessor::processActivities()

3 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Provider/MagicFunctionProvider.php(89): civicrm_api3_job_fetch_activities((Array:1))

4 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(169): Civi\API\Provider\MagicFunctionProvider->invoke((Array:9))

5 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(100): Civi\API\Kernel->runRequest((Array:7))

6 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/api.php(23): Civi\API\Kernel->runSafe("job", "fetch_activities", (Array:1), NULL)

7 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/JobManager.php(145): civicrm_api("job", "fetch_activities", (Array:1))

8 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/JobManager.php(79): CRM_Core_JobManager->executeJob(Object(CRM_Core_ScheduledJob))

9 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/v3/Job.php(99): CRM_Core_JobManager->execute(FALSE)

10 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Provider/MagicFunctionProvider.php(89): civicrm_api3_job_execute((Array:2))

11 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(169): Civi\API\Provider\MagicFunctionProvider->invoke((Array:9))

12 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(100): Civi\API\Kernel->runRequest((Array:7))

13 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/api/api.php(23): Civi\API\Kernel->runSafe("Job", "execute", (Array:2), NULL)

14 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/bin/cli.class.php(113): civicrm_api("Job", "execute", (Array:2))

15 /home/oursite/public_html/wp-content/plugins/civicrm/civicrm/bin/cli.php(32): civicrm_cli->callApi()

( [message] => Could not connect to MailStore for [email protected]<p>Error message: <pre>An error occured while sending or receiving mail. The POP3 server did not accept the password: -ERR [AUTH] Authentication failed. .</pre><p> [code] => ) –

  • Hi @fdarn, what are the error logs you can find. An http 500 suggests some PHP error and is written in the apache error logs. Did you have the option to examine them. Commented Dec 13, 2017 at 22:21
  • hi. I found the Civi ConfigAndLog files. I added some of the errors I found above
    – fdarn
    Commented Dec 14, 2017 at 0:18
  • And I confirmed that the password does work for that email.
    – fdarn
    Commented Dec 14, 2017 at 0:20

1 Answer 1


I've found that almost all of our 500 errors have been server related, such as a security issue being run into with the site. I usually work with the host to see if they can find something in their logs. The only other reason I've gotten a 500 error was when something in my php settings wasn't set high enough (like memory allocated, execution time for a script, etc).

Usually my host will have me run through the steps to recreate it (making sure they have my IP address) and they will watch for any related errors.

  • We have been working with the host and they showed us the same errors. They have no answer either. I installed Civi on a different domain that is hosted by the same company and had no issues. So I think it was a bad install when we upgraded to 4.7.27. I am now going to change course and install it on a subdomain and hopefully be able to run it off that instead of the main domain where we are having problems.
    – fdarn
    Commented Dec 14, 2017 at 13:37
  • It could indeed be a corrupted install. I've had that happen before and had to redo it. I work with two servers at the same company and can have plenty of problems on one server that I don't on the other. Sometimes I may have a custom php.ini file on one server that I don't the other. Or the other is newer and its settings are different. Same host doesn't necessarily mean you're working with two exact same environments. Commented Dec 14, 2017 at 20:51
  • Tell me about it. I am noticing all kind of differences in the two servers. Do you have any of your civi installs on a Subdomain? Or are they all on the root?
    – fdarn
    Commented Dec 14, 2017 at 20:55
  • I do have an install on a subdomain, but there's also a Drupal install attached to it (it's the dev version of the live site). I've always had my Civi and my site installed on the same domain or subdomain. Commented Dec 14, 2017 at 22:00
  • Okay. Just wondering, because I installed on a subdomain today and apparently some of the paths need to be changed.
    – fdarn
    Commented Dec 14, 2017 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.