1

When editing contacts in Civicrm i've been receiving one of two errors, I'm worried these are going to cause further issues down the line.

-An error with no error message:

BACKTRACE

#0 /var/www/elmsln/domains/community/sites/default/files/civicrm/ext/ca.bidon.reporterror/reporterror.php(266): reporterror_civicrm_generatereport("Marrickville Legal Centre", (Array:2), NULL, (Array:0))
#1 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Error.php(365): reporterror_civicrm_handler((Array:2))
#2 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/DAO.php(1094): CRM_Core_Error::fatal()
#3 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Contact/BAO/Contact/Permission.php(150): CRM_Core_DAO::getFieldValue("CRM_Contact_DAO_Contact", NULL, "is_deleted")
#4 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Dashlet/Page/Activity.php(61): CRM_Contact_BAO_Contact_Permission::allow(NULL, 1)
#5 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Invoke.php(309): CRM_Dashlet_Page_Activity->run((Array:3), NULL)
#6 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Invoke.php(84): CRM_Core_Invoke::runItem((Array:13))
#7 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))
#8 /var/www/elmsln/domains/community/sites/all/modules/civicrm/drupal/civicrm.module(448): CRM_Core_Invoke::invoke((Array:3))
#9 [internal function](): civicrm_invoke("dashlet", "activity")
#10 /var/www/elmsln/domains/community/includes/menu.inc(527): call_user_func_array("civicrm_invoke", (Array:2))
#11 /var/www/elmsln/domains/community/index.php(21): menu_execute_active_handler()
#12 {main}

-And another:

ERROR

message: Could not find valid value for ct code:

BACKTRACE

#0 /var/www/elmsln/domains/community/sites/default/files/civicrm/ext/ca.bidon.reporterror/reporterror.php(266): reporterror_civicrm_generatereport("Marrickville Legal Centre", (Array:2), NULL, (Array:0))
#1 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Error.php(365): reporterror_civicrm_handler((Array:2))
#2 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Utils/Request.php(120): CRM_Core_Error::fatal("Could not find valid value for ct")
#3 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Contact/Form/Contact.php(163): CRM_Utils_Request::retrieve("ct", "String", Object(CRM_Contact_Form_Contact), TRUE, NULL, "REQUEST")
#4 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Form.php(543): CRM_Contact_Form_Contact->preProcess()
#5 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Upload.php(129): CRM_Core_Form->buildForm()
#6 /var/www/elmsln/domains/community/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Upload->perform(Object(CRM_Contact_Form_Contact), "upload")
#7 /var/www/elmsln/domains/community/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Contact_Form_Contact), "upload")
#8 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Controller.php(351): HTML_QuickForm_Page->handle("upload")
#9 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Utils/Wrapper.php(113): CRM_Core_Controller->run()
#10 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Invoke.php(283): CRM_Utils_Wrapper->run("CRM_Contact_Form_Contact", "New Contact", (Array:1))
#11 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Invoke.php(84): CRM_Core_Invoke::runItem((Array:13))
#12 /var/www/elmsln/domains/community/sites/all/modules/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))
#13 /var/www/elmsln/domains/community/sites/all/modules/civicrm/drupal/civicrm.module(448): CRM_Core_Invoke::invoke((Array:3))
#14 [internal function](): civicrm_invoke("contact", "add")
#15 /var/www/elmsln/domains/community/includes/menu.inc(527): call_user_func_array("civicrm_invoke", (Array:2))
#16 /var/www/elmsln/domains/community/index.php(21): menu_execute_active_handler()
#17 {main}
5

-An error with no error message:
The error looks like the user is not logged in. Did you faced the problem after logging out and logging in?

Could not find valid value for ct code: This happens when 'ct' (contact type) param is missing is url. Usually happens when you try to visit the New Contact form and you are log out and then after logging in you might face this type of error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.