0

When trying to complete a contribution using ACH/EFT our donation page (http://www.thewellspringfoundation.org/donate) is asking donors to enter their banking information twice.

The form is asking for the Name of the Account Holder, Account Number, Bank Number + Transit Number, and Bank Name in the Direct Debit Information section before the Billing Name and Address section AND then after the Billing Name and Address section it is asking for Transit Number, Bank Number, and Account Type. After filling in all the info, the Contribute button is greyed out. I believe this is because the Bank Account Number field is not displayed in the lower section, which I believe is generated by the iATS extension. See screenshot:

Donation form with ACH/EFT selected as Payment Method

I have also noticed that the 'cheque' image is not found, as it it looking in the wrong place, the absolute path to the file, which could be due to something in my directories settings(?!?).

I upgraded to CiviCRM 4.7.28 earlier today. I am using CiviCRM in Wordpress 4.9.1. I have the following Extensions active in CiviCRM:

  • iATS Payments 1.6.1
  • Summary Fields v. 3.1.1
  • Extended Report v. 3.0
  • Displays relationships in the contact summary v. 1.2
  • Mailchimp v. 2.0.1
0

Exactly - the broken image for the cheque display tells us that the template/js from the iATS Extension are not loading properly

enter image description here

First thing to do is to check your Resource Settings URL: civicrm/admin/setting/url?reset=1 specifically the Extension Resource URL

Second thing to do is to start up a browser inspector tools - and check the console -> for javascript errors when you load the page;

  • Thanks Karin. I've checked my Extension Resource URL. It was [civicrm.files]/ext/ so I changed it to [civicrm.files]/custom_ext/ which is the same as I have for the Extensions Directory. I still cannot see the cheque image, but now I cannot see the broken image either. – jursulak Dec 15 '17 at 19:14
  • I've worked it out. I changed the path from [civicrm.files]/ext/ to wp-content/plugins/files/civicrm/custom_ext/ and it is working. – jursulak Jan 12 '18 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.