4

The date format in the CiviCrm event list widget switch not to german format. I administer all known format settings to the german settings. But only in the event list widget it shows no effect. Is there an option that I not found? I use wordpress 4.9.1 with Tortuga and CiviCrm 4.7.27

2
  • 1
    Hej Grischan, did you managed this issue? Maybe you like to share your solution? I have the same problem here. Best
    – wintermoor
    Commented Aug 19, 2020 at 11:16
  • @wintermoor i changed your ANswer to a comment. perhaps you do not yet have 'reputation' to add comments. but we can't leave an 'i have this problem too' as an answer. sorry. but it would just get down marks.
    – petednz - fuzion
    Commented Aug 19, 2020 at 20:20

2 Answers 2

2

Set default via Administer -> Localisation -> Date Formats Date Format: Time Only %H:%M

Events use the activityDateTime, which can be adjusted here: Administer -> Customise Data and Screens -> Date Preferences

This will change event descriptions, confirmation mails and such. If you use a CiviEvent calendar, it's view is not corrected though.

0

Go to /wp-content/plugins/civievent-widget and edit following values written in 'single quotation marks' in civievent-widget.php:

  • Change date from '%b %E, %Y' to '%d.%m.%Y' in line 192 (date).
  • Change time frome '%l:%M %p' to '%H:%M' in line 196.
  • You may like to change the title 'Upcoming Events' in line 173, too.

Please note that the next update of this plugin will override these settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.