1

I have CiviCRM 4.6.28 on Drupal 7.56, hosted on Pantheon.

We are trying to import lists of contacts, but anything above 250 contacts throws a timeout error, due to Pantheon's time limits. The time limit is 240 seconds, and the files vary between 14 and 30 kbs.

I've traced the resource usage back to find that the issue is that Smarty is being used during the import. Pantheon is showing Smarty as using a lot of resources, and I believe this is the issue because we can import event participants without problem, and the only difference in resource usage seems to be that event participant imports don't use Smarty.

So, now I am trying to figure out how to get it to stop using Smarty during import. I am thinking that it is using it for handling the email greetings field. Is there a way to turn off this field? We do not have special e-mail greetings for users.

1

The speed you experience seems to be much slower than usual (not that contact imports are super fast, but civi can do better than 1 per second ;)

What is the field mapping you use? the less fields you import, the faster it's going to be (mostly true, some are more expensive than others, eg current employer if you import individuals)

Are the salutations one of the fields you alter?

What is the dedupe rule you use? Some of the out of the box rules are optimised, but if you create and use your own, it might end up being super slow

What is the rule you use? update data is more expensive than ignoring duplicates, skip or replace

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.