I am seeing unusual behavior when trying to insert a profile as a directory on the front end of WP.

https://my.url.org/state-chairs/?page=CiviCRM&q=civicrm/profile&force=1&gid=21

https://my.url.org/states/?page=CiviCRM&q=civicrm/profile&force=1&gid=19

They should be showing two different data sets but are only showing the same data? I checked that the profile has the proper group selected.

Also it says as an admin I do not have permission to access this page: https://my.url.org/states/ When I visit there it says:

Permission Denied You do not have permission to view this contact record. Contact the site administrator if you need assistance.

I am running CiviCRM 4.7.27 on WP 4.9.1. This is a multisite.

  • It would be helpful if you could be more specific about how you're trying to achieve your goal. Have you tried using a shortcode? Or are you relying on the querystring to be present? – Christian Wach Dec 20 '17 at 10:13
  • This is using a shortcode: e.g. [civicrm component="profile" gid="19" mode="view" hijack="0"] – Andy Burns Dec 20 '17 at 15:58

Ah, that moment when you bump into a question you figured out but I forgot I even posted it here.

There may be other methods but you should use the native CiviCRM profile link which you can find at Administer > Profiles > more > Use- Listings Mode. This looks like: https://example.org/civicrm/?page=CiviCRM..." format or whatever you set your base page at.

The issue seems to be if you try and use a shortcode for this directory style listing and not use the CiviCRM base page. So, you can create a clean URL to redirect to the native CiviCRM profile link. Perhaps this is considered a workaround but it works :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.