4

After upgrading to CiviCRM 4.7.28 in WordPress, when users are trying to draft mailings in CiviMail using a template (which contains unsubscribe/opt out/resubscribe/subscribe tokens, the {domain.address} token, and URLs to our website and Facebook), when CiviMail tries to autosave the draft, the user gets this error message:

"Mailing has not been saved, Content maybe out of date, please refresh the page and try again"

This error does NOT occur when not using a template, but if you use a template when you start a message, and then delete it, the error does continue to occur. It seems like it's related to the template but I can't really understand why.

Anyone have any ideas on why this would be occurring and how to fix it?

4
  • Update: The error actually does happen if you don't use the template but you paste in content created by our template...
    – Erica W
    Dec 21, 2017 at 20:11
  • If I disable the CKEditor and use Textarea instead, in Adminster > Customize Data and Screens > Display Preferences > WYSIWYG Editor, then the error goes away, but of course that deletes the WYSIWYG functionality.
    – Erica W
    Dec 21, 2017 at 20:43
  • I've been seeing this reported by multiple staff members at a client that recently was updated to 4.7.28 (Drupal 7)
    – ericG
    Dec 23, 2017 at 0:28
  • The error was resolved by disabling CKEditor in favor of Textarea. The next day I switched back to CKEditor and the error did not reoccur with or without templates! A strange little problem but hopefully solved now.
    – Erica W
    Dec 31, 2017 at 22:22

5 Answers 5

3

I puzzled over this problem after a 4.7.28 upgrade for hours before reading this post. Turning off and on Ckeditor worked for me, which gave me another idea.

Since this happened to me with two sites, I tried clearing all caches on the second site and that did the trick. I suspect changing the ckeditor setting flushes a cache, and flushing the cache is the real fix.

I flushed all the caches I have so I'm not sure which is the one that really does the trick:

2
  • 1
    On Drupal 8, it was the menu rebuild (which also clear some Civi-specific caches) that worked for me. Feb 5, 2018 at 19:18
  • It's clearing the caches that does the job. (Wordpress, CiviCRM 4.7.29)
    – fred2
    Feb 9, 2018 at 19:02
1

If I remember correctly, I had this happen one time and it was faulty html in what I was pasting in. I figured it out by pasting only a little piece of the code in at a time to find the part where I got the error.

2
  • Thanks for the suggestion! I went through and tested the HTML, as you suggested, and everything was fine. (But a good exercise regardless.) Turned out to be solved by disabling and reenabling CKEditor.
    – Erica W
    Dec 31, 2017 at 22:24
  • Good, glad to hear that disabling/enabling that worked. Odd! I'll have to remember that for next time. Thus far it's always been because of some rouge bit of code (usually because of pasted in Word stuff). :) Jan 1, 2018 at 1:23
1

I had the same error appear after upgrading from 4.7.24 to 4.7.29 (wordpress). I was able to regain mail functionality by following the instructions above to disable the CKEditor - however, as stated above you lose the WYSIWYG functionality...

1
  • Thanks, I was able to solve the problem just by disabling CKEditor and then reenabling CKEditor again the next day. Go figure!
    – Erica W
    Dec 31, 2017 at 22:23
1

I managed to trigger this error after upgrading to 5.0 (probably a directory permissions error). Deleting the cache files as Jamie describes above AND doing the menu rebuild seems to have repaired the problem.

1

I ran into this because the database had not yet been converted to utf8mb4 (it was an old installation of CiviCRM).

Example: go to the Support > Developer > Api3 Explorer, then run entity = "System", and action = "utf8conversion".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.