4

I'm getting the Incorrect Resource URL warning on both an upgrade and a fresh install on WordPress 4.9.1 on an nginx external dev site and on an nginx local site (using Local by Flywheel for the environment).

Nevertheless, the arrows in the menus are present, at least this is what I see:

arrows in menu

I'm new to CiviCRM so likely missing something obvious. Any pointers on how to debug this would be appreciated.

4

I'm starting to regret having written this check!

So far, I have found four scenarios that result in this false positive:

  • Your php.ini has allow_url_fopen set to false. This should be corrected, since it will subtly break other parts of CiviCRM (e.g. extension download, update checks).
  • Your site is behind a .htpasswd, and thus needs HTTP authentication to access files.
  • You're using WordPress, which has some much discussed issues regarding its ability to detect the directory its in when there's a symlink. Follow the third link ("issues") for a discussion of how to fix this until the WordPress-Civi wizards resolve this once and for all.
  • Your server's firewall is configured to reject HTTP requests to itself. I don't know a way to test for this other than to SSH in and run netcat, something like nc -v <my ip address> 80. You want a connection that's "open" rather than "refused". Note that using localhost instead of the local IP address in that netcat command may yield a different result.
  • it also seems to give a false warning sometimes when Drupal maintenance mode is enabled. no good deed.. – ericG Dec 23 '17 at 0:20
  • I think maybe instead of checking for a "200" HTTP response, I should check for the existence of a "4xx" or "5xx" response. I'll consider that. – Jon G - Megaphone Tech Dec 23 '17 at 0:32
  • I've also noticed the same issues on my joomla test sites. I do think testing for 400 or 500 errors would be better, – Kevin Cristiano Dec 23 '17 at 2:53
  • @JonG-MegaphoneTech, thanks for jumping in so quickly. None of the three scenarios solve it for me. 1 and 3 don't apply and using the fix in the "issues" link doesn't fix it. Can I assume for now that this is a false positive and ignore it until you and the other wizards get it sorted out? – rgilman Dec 23 '17 at 6:15
  • I'd say yes! @rgilman – Jon G - Megaphone Tech Dec 23 '17 at 22:07
2

If you have a Security Plugin that filters based on user agent that will block the check and result in a false positive. https://issues.civicrm.org/jira/browse/CRM-21629

If you are using a local site or dev site that isn't connected to a real URL this check will also fail. You can solve this by editting the host file on the machine the site is running on.

0

Make sure that php is upgraded to version 7.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.