1

I am running Drupal 7.56, with PHP 5.6.31.

I upgraded to CiviCRM 4.7.29, and now my membership renewal page .../civicrm/contribute/transact?id=1 comes up with HTTP ERROR 500.

The PHP error log shows this: PHP Fatal error: require_once(): Failed opening required 'CRM/Core/.php'

It is trying to load a ".php" with no name before the extension. What could cause that?

  • I am on Joomla 3.8.3, upgraded to 4.7.29 and it broke my contribution page. Any help with a fix would be much appreciated. My test site running 4.7.28 works fine. – Hudson Essex Terraplane Club Dec 23 '17 at 15:39
  • When I compare the .29 contribution.php file in github to the one on my site, it does not appear that the changes have been made. Is it possible there is an issue with the update file? – Hudson Essex Terraplane Club Dec 23 '17 at 16:04
  • I made the changes in contributionbase.php that Eileen recommended in the above Files changed tab and my contribution page is working again. – Hudson Essex Terraplane Club Dec 24 '17 at 3:51
  • I just ran the same fix on my site running Drupal 7.56 upgraded CiviCRM to 4.7.29. PHP 7.0. Praise God! Works! So glad I stumbled onto this. Don't know how widespread the issue is, how many others may be suffering, but I've been searching for a solution for two weeks! – John Richardson Jan 5 '18 at 1:17
2

I am running Joomla and ran into the same issue. I was able to correct it by applying the changes on this page: https://github.com/civicrm/civicrm-core/pull/11454/files

  • Thanks, it worked for me too on one of two Joomla 3.8.3s broken by 4.7.29 (curiously another one worked fine without) – Nic Jan 23 '18 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.