1

I have just upgraded to 4.7.29.

When i go to manage>screens>navigation menu... the navigation menu won't load. It keeps loading. What can i do to resolve this? enter image description here

error log when I try to rebuild:

[info] $ManagedEntities_failed = Array ( [entity] => RelationshipType [action] => create [params] => Array ( [version] => 3 [name_a_b] => Case Coordinator is [name_b_a] => Case Coordinator [label_a_b] => Case Coordinator is [label_b_a] => Case Coordinator [description] => Case Coordinator [contact_type_a] => Individual [contact_type_b] => Individual [contact_sub_type_a] => [contact_sub_type_b] => )

[result] => Array
    (
        [error_code] => already exists
        [sql] => INSERT INTO civicrm_relationship_type (name_a_b , label_a_b , name_b_a , label_b_a , description , contact_type_a , contact_type_b , is_active ) VALUES ('Case Coordinator is' , 'Case Coordinator is' , 'Case Coordinator' , 'Case Coordinator' , 'Case Coordinator' , 'Individual' , 'Individual' ,  1 )  [nativecode=1062 ** Duplicate entry 'Case Coordinator is' for key 'UI_name_a_b']
        [tip] => add debug=1 to your API call to have more info about the error
        [is_error] => 1
        [error_message] => DB Error: already exists
        [debug_information] => INSERT INTO civicrm_relationship_type (name_a_b , label_a_b , name_b_a , label_b_a , description , contact_type_a , contact_type_b , is_active ) VALUES ('Case Coordinator is' , 'Case Coordinator is' , 'Case Coordinator' , 'Case Coordinator' , 'Case Coordinator' , 'Individual' , 'Individual' ,  1 )  [nativecode=1062 ** Duplicate entry 'Case Coordinator is' for key 'UI_name_a_b']
    )

)

Dec 31 14:48:09 [info] $Fatal Error Details = array(3) { ["message"]=> string(35) "API error: DB Error: already exists" ["code"]=> NULL ["exception"]=> object(Exception)#10841 (7) { ["message":protected]=> string(35) "API error: DB Error: already exists" ["string":"Exception":private]=> string(0) "" ["code":protected]=> int(0) ["file":protected]=> string(90) "/home/kmdero1q/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/ManagedEntities.php" ["line":protected]=> int(456) ["trace":"Exception":private]=> array(13) { [0]=> array(6) { ["file"]=> string(90) "/home/kmdero1q/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/ManagedEntities.php" ["line"]=> int(234) ["function"]=> string(10) "onApiError" ["class"]=> string(24) "CRM_Core_ManagedEntities" ["type"]=> string(2) "->" ["args"]=> array(4) { [0]=> string(16) "RelationshipType" 1=> string(6) "create" [2]=> array(10) { ["version"]=> int(3) ["name_a_b"]=> string(19) "Case Coordinator is" ["name_b_a"]=> string(16) "Case Coordinator" ["label_a_b"]=> string(19) "Case Coordinator is" ["label_b_a"]=> string(16) "Case Coordinator" ["description"]=> string(16) "Case Coordinator" ["contact_type_a"]=> string(10) "Individual" ["contact_type_b"]=> string(10) "Individual" ["contact_sub_type_a"]=> NULL ["contact_sub_type_b"]=> NULL } ....

1

What version of CiviCRM are you using? Can you check for any Javascript error on browser?

Try rebuilding menu by running /civicrm/menu/rebuild?reset=1 or clearing CiviCRM cache.

  • I upgraded to 4.7.29 (latest version). Rebuiling menu didn't help. Already tried clearing cache. – DirkVanRoy Dec 31 '17 at 9:51
  • Anything in CiviCRM logs? – Pradeep Nayak Dec 31 '17 at 10:06
  • now i see an error : Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. API error: DB Error: already exists – DirkVanRoy Dec 31 '17 at 11:44
  • Can you please paste detail of DB Error from CiviCRM log? You can find it under /pathtodrupalfolder/sites/default/files/civicrm/ConfigLog/ – Pradeep Nayak Dec 31 '17 at 13:01
  • have it pasted above; it is a wordpress website – DirkVanRoy Dec 31 '17 at 13:59
1

My status on this forum would not allow me to add a comment to the original question, though my earlier 'answer' seems to have given me the points to now do so, so I have removed my earlier 'me too' answer.

We too were seeing this issue. However, our error was somewhat different. In addition to the menu screen not loading, we were also seeing an inability to create or edit mailings, load the status page, or load the icons in the menu.

Our error looked more like this:

$Fatal Error Details = array(3) {
  ["message"]=>
  string(23) "DB Error: no such field"
  ["code"]=>
  NULL
  ["exception"]=>
  object(CiviCRM_API3_Exception)#254 (8) {
    ["extraParams":"CiviCRM_API3_Exception":private]=>
    array(6) {
      ["error_code"]=>
      string(13) "no such field"
      ["sql"]=>
      string(1021) "SELECT a.id as `id`, a.is_active as `is_active`, a.group_type as `group_type`, a.title as `title`, a.description as `description`, a.help_pre as `help_pre`, a.help_post as `help_post`, a.limit_listings_group_id as `limit_listings_group_id`, a.post_URL as `post_URL`, a.add_to_group_id as `add_to_group_id`, a.add_captcha as `add_captcha`, a.is_map as `is_map`, a.is_edit_link as `is_edit_link`, a.is_uf_link as `is_uf_link`, a.is_update_dupe as `is_update_dupe`, a.cancel_URL as `cancel_URL`, a.is_cms_user as `is_cms_user`, a.notify as `notify`, a.is_reserved as `is_reserved`, a.name as `name`, a.created_id as `created_id`, a.created_date as `created_date`, a.is_proximity_search as `is_proximity_search`, a.cancel_button_text as `cancel_button_text`, a.submit_button_text as `submit_button_text`
FROM civicrm_uf_group_en_US a
WHERE (a.name IN ("new_individual", "new_organization", "new_household")) AND (a.is_active = "1")
LIMIT 25
OFFSET 0
 [nativecode=1054 ** Unknown column 'a.cancel_button_text' in 'field list']"

$backTrace = #0 /civicrm/CRM/Core/Error.php(456): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /civicrm/CRM/Core/Invoke.php(55): CRM_Core_Error::handleUnhandledException(Object(CiviCRM_API3_Exception))
#2 /civicrm/drupal/civicrm.module(448): CRM_Core_Invoke::invoke((Array:4))
#3 /var/www/vhosts/docorg.ca/httpdocs/includes/menu.inc(527): civicrm_invoke("ajax", "l10n-js", "en_US")
#4 /var/www/vhosts/docorg.ca/httpdocs/index.php(21): menu_execute_active_handler()
#5 {main}

Investigation lead to an existing (resolved) issue in the CiviCRM issue queue: "4.7.28-rc: needs to call rebuildMultilingualSchema()" https://issues.civicrm.org/jira/browse/CRM-21481

In our case, we were still getting the error after an update from 4.7.27 in 4.7.29 on Drupal 7 - our site is multilingual English and French.

The solution for us, as suggested in the issue, was to manually call a rebuild of the multilingual schema using the following drush command:

$ drush php-eval 'civicrm_initialize(); CRM_Core_I18n_Schema::rebuildMultilingualSchema(["en_US","fr_FR"], NULL);'

There is a WordPress option as well, find the info here: https://gist.github.com/mlutfy/647e6325a09079e4f08f273af64900d9

  • note, we needed "fr_FR" not "fr_CA" as in the example, replace with whichever language code you have enabled.

Unfortunately, if you're not running a multi-lingual site, I'm not sure what to suggest.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.