1

I am using Civi 4.7.29 on Wordpress 4.9.1

When exporting the membership list for postal mailing, the expiration date is shown as YYYY-MM-DD. I would really like it to be MM-DD-YYYY.

To export I go to Search>Find Memberships, I select my membership type then scroll to the bottom and click search. On the next page I select All Records, then select Export Members from the drop down menu.

Is there a better way of doing this to get the date format I need, or are there some settings I can change? The Localization > Date Formats do not seem to cover the exports.

Thank you.

5

Yes, Date fields in export do not respect Date formats set in Localization >> Date Formats. Can you try Format Date Column in Export extension? This extension allows to set Export Date format under Localization >> Date Formats and uses this to format the date fields while exporting.

  • That extension is not available on my extension list. And those instructions appear to be outdated, as this page doesn't exist in my menu Administer >> Customize Data and Screens >> Manage Extensions. I am using Civi 4.7.29. I did find this configurations page Settings - Date Preferences, and I tried changing the formats for Searchdata and mailing, but it is still exporting the same way. – fdarn Dec 31 '17 at 17:25
  • The extension won't be available for auto download since its not released. You will need to manually download the extension into your extension directory and then perform install. The setting in Date Preference will be available upon enabling 'Format Date Column in Export' extension. – Pradeep Nayak Dec 31 '17 at 17:44
  • Please let me know how it goes so that i can go ahead and release the extension for public usage. – Pradeep Nayak Dec 31 '17 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.