3

Using the payment processor PayPal_Standard on a fresh install of CiviCRM Version 4.7.29 (with Wordpress 4.9.1 on Centos 7.4) breaks all contribution pages where PayPal is enabled. The result is a blank page. In the Apache error log there is:

PHP Fatal error: require_once(): Failed opening required 'CRM/Core/.php' (include_path='.:/somedir/wp-content/plugins/civicrm/civicrm:/somedir/wp-content/plugins/civicrm/civicrm/packages:/somedir/wp-content/plugins/civicrm/civicrm/vendor/tecnickcom:/somedir/wp-content/plugins/civicrm/civicrm/vendor/phpseclib/phpseclib/phpseclib:/somedir/wp-content/plugins/civicrm/civicrm/vendor/pear/pear_exception:/somedir/wp-content/plugins/civicrm/civicrm/vendor/pear/auth_sasl:/somedir/wp-content/plugins/civicrm/civicrm/vendor/pear/net_socket:/somedir/wp-content/plugins/civicrm/civicrm/vendor/pear/net_smtp:/somedir/wp-content/plugins/civicrm/civicrm/ve in /somedir/wp-content/plugins/civicrm/civicrm/Civi/Payment/System.php on line 59, referer: https://someurl/civicrm/?page=CiviCRM&q=civicrm/contribute/transact&reset=1&id=1

When disabling PayPal (= pay later) the contribution pages work fine.

Any ideas what might be going wrong here?

3

You're experiencing the bug documented at CRM-21595. You will need to apply the patch or wait for CiviCRM 4.7.30.

Most people won't experience this bug if they disable "Pay Later" as an option.

  • Phew, that worked for me too – Jon-man Jan 24 '18 at 10:48
  • Weehaww! Worked for me. No "Pay Later" on my configs, but still got the bug. Applied patch and everything is back to normal! Thanks, Jon! – John Richardson Feb 1 '18 at 5:12
1

You can install the rc for 4.7.30 which is what I recommend - it's at download.civicrm.org/latest

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.