1

I upgraded CiviCRM from 4.7.28 to 4.7.29. CiviVolunteer is at 4.7.21-2.2.3. I have active projects but the "Manage Volunteer Projects" screen comes up blank. The "Search for Volunteer Opportunities" reports "No results found".

I can create a new project, but it also doesn't show up. I see the projects in the database (civicrm_volunteer_project), although I noticed the new project I tried to create is listed in three identical records.

I have Angular Profiles 4.6-1.0.2 and am on WordPress 4.9.1.

I tried "cv flush" as described in https://issues.civicrm.org/jira/browse/CRM-21210.

2

I'm not sure this was the problem, but the default PHP interpreter was at 7.1. I noticed CiviEvent was also not working (error message about "pass by reference"). I set PHP back to 5.6 and both CiviEvent and CiviVolunteer seem to be working.

The CiviCRM status screen is giving notice "PHP Out-of-Date: This system uses PHP version 5.6.32. This meets the minimum recommendations and you do not need to upgrade immediately, but the preferred version is 7.0."

Update July 3 2018: Currently at CiviCRM 5.2.2 with CiviVolunteer 4.7.31-2.3.1 and was able to move to PHP 7.1.18 with no issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.