2

I recently moved from linod sever to Wp-Engine server. I did the migration but Civicrm plugin wont work. I see it in the sidebar but when I click on it to access it I get a Http 500 page not found error. I am unsure what to do to fixed it.

3

You should double check your civicrm_settings.php file. Particularly the section on File System Paths. Make sure the setting $civicrm_root is the correct path to civicrm for the new server.

Hope this helps...

2

WP Engine is a quirky host--it makes lots of configuration decisions for you with the goal of optimizing for WordPress sites, but that often makes things more difficult for CiviCRM. This is in stark contrast to Linode, where you have full control over your hosting configuration.

A 500 error could be any number of things; you'll need to find a log message to tell you more, and I'm not certain where exactly this is on WP Engine.

However, for examples of WP Engine-specific quirks, you might look at the following other questions:

  • [Fri Jan 05 17:10:50.413260 2018] [:error] [pid 7021] [client 73.181.6.230:53278] PHP Fatal error: require_once(): Failed opening required 'CRM/Core/ClassLoader.php' (include_path='.:/var/www/stlukespaa.org/wp-content/plugins/civicrm/civicrm/:/var/www/stlukespaa.org/wp-content/plugins/civicrm/civicrm//packages:.:/usr/share/pear/php:/usr/share/php:/usr/share/pear') in /nas/content/live/stpaa/wp-content/plugins/civicrm/civicrm.settings.php on line 357, referer: stlukespaa.org/wp-admin/plugins.php – Matthew Plamp Jan 5 '18 at 17:45
  • 2
    You may want to double check your civicrm_settings.php file. Particularly the path to civicrm and make sure it is correct for the new server. – KilakwaBT Jan 5 '18 at 18:15
  • 1
    @KilakwaBT want to post your comment as a separate answer? I agree with your assessment - I don't think this is a WPEngine issue, I think it's an incomplete migration issue with the old filesystem path retained in civicrm.settings.php (or possibly somewhere else, eg DB or another config file). – Chris Burgess Jan 8 '18 at 18:42
  • @ChrisBurgess Just added it as an answer. Thanks. – KilakwaBT Jan 8 '18 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.