4

I've installed the Email API for CiviRules, but nothing about emails is showing up under actions in CiviRules. Have tried uninstalling and reinstalling, but no change. Is there another step that I need to be taking to enable email sending?

CiviCRM 4.6.33 on Drupal 7.56, CiviRules 1.15, Email API 1.10.

3

Updating https://github.com/CiviCooP/org.civicoop.emailapi to version 1.11 appears to have fixed this!

  • Indeed, fixed in 1.11! – Lars SG Jan 7 '18 at 19:00
3

You should try to clear CiviCRM's cache as mentioned in CiviRules' documentation :

If you add your action as a a managed entity (which we think is a good idea) you will obviously have to do a {yoursite}/civicrm/clearcache to make sure the new managed entity is available.

Cheers, Olivier;

  • 1
    I've tried that, but still no luck. – Lars SG Jan 6 '18 at 5:20
2

I encountered the same issue a month ago. After installing both the E-MAIL API and CiviRules I wasn't able to select send email rule, but I could send emails through the API explorer.

In other words everything was working only I wasn't able to select send email action when I defined rules. It turned out that a row was missing from the civirule_action table of the CiviCRM database.

I fixed the issue by adding the missing row (copied over from the CiviCRM instance with working CiviRules) with name emailapi_send label Send e-mail and class CRM_Emailapi_CivirulesAction.

The table that works should look like this:

enter image description here

I don't know what caused it, but I suspect the issue arose because CiviRules and E-MAIL API extensions were uninstalled and then installed again couple of times trying to resolve an unrelated issue. I was using the newest CiviCRM version at the time (4.7.27)

2

Ok, so did a combination of the above to fix this on WordPress install:

Added the SQL statement manually:

INSERT INTO civirule_action (name, label, class_name, is_active)
VALUES('emailapi_send', 'Send E-mail', 'CRM_Emailapi_CivirulesAction', 1);

Deleted the plugin, manually added the v1.11, refreshed cache and it installed properly. After I was able to execute the v1.7 upgrade and complete the database update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.