1

I upgraded our test site to 4.7.29 (type fixed) yesterday and the cron has been failing since then with a 500 server error.

We are running on Wordpress 4.9.2. The cron has been working successfully until now for years.

We have a cron job running every 30 minutes using the URL to cron.php method. I've checked the cron.php permissions; they haven't changed and have checked that the user and password are still valid and have enough permission (they do). When I run the command directly from the command line I also get a 500 internal server error, same with running it in a browser. The only thing we did was upgrade the version of CiviCRM. Help?

3
  • Try upgrading it to 4.7.29 . Jan 17, 2018 at 20:41
  • Can you paste the error log please. Jan 17, 2018 at 22:25
  • Sorry - that was a typo. It is version 4.7.29
    – Jane
    Jan 18, 2018 at 4:44

1 Answer 1

1

So I resolved the issue. Here's what I found. It looks like the permissions for bin have changed from 755 to 775 at some point (I looked at one of our backups and it used to be 755, but in 4.7.29 it was set to 775.)

I used this question and response: URL for cron Jobs gives me a 404 error (not the same error, but I was desperately searching!)

Made the same changes (updated bin permissions to 755) and it all worked. So that's good (for now) but with every upgrade will we have to remember to update permissions?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.