1

WordPress 4.9.2 CiviCRM 4.7.29

I'm trying to upgrade to PHP 7 from 5.5, but CiviCRM mailer stops working. The Send test email results in: enter image description here

To verify the email settings I used Easy WP SMTP enter image description here

And it is able to send a test email. enter image description here

The server does not support SSL or TLS. Any ideas about what to try next?

  • Can you double check the port in the CiviMail, it looks to be set to 567 in the screenshots. – Kevin Cristiano Jan 17 '18 at 19:56
  • Thank you for noticing that. I'm getting authentication errors now in PHP 5.5.38. Does Settings - Outbound Mail reset the SMTP password if you change the configuration port or server? – Codedogs Jan 17 '18 at 21:19
  • I would reenter the password to be certain. – Kevin Cristiano Jan 17 '18 at 21:25
  • Yes authentication errors = wrong password. – Codedogs Jan 18 '18 at 17:18
1

It's likely that you've added (or removed) the php-crypt library in your PHP upgrade process. This would cause your password to be encrypted in an incompatible method. Re-enter your credentials or match your php-crypt to what it was previously.

  • If that were the case, why did Easy WP SMTP not have the same problem? This is not the first time I've had this problem. – Codedogs Jan 18 '18 at 17:16
  • If the problem is what I'm suggesting it is, then the issue isn't SMTP - it's how the credentials are stored in the database. I have no idea how Easy WP SMTP stores its credentials in the database. – Jon G - Megaphone Tech Jan 18 '18 at 17:43
  • All other sites are working fine but currently it gives some error as "The e-mail could not be sent. Possible reason: your host may have disabled the mail() function..." – Vishal Kumar Sahu Jun 14 '18 at 19:59
  • @VishalKumarSahu That sounds like a different problem. – Jon G - Megaphone Tech Jun 14 '18 at 21:01
1

Check this answer on the SE question SMTP connection failing problem. Seems related with your problem due to the PHP update above version 5.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.