0

Notice: Use of undefined constant DIR - assumed 'DIR' in /home/yonatony/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/ClassLoader.php on line 127

Notice: Use of undefined constant DIR - assumed 'DIR' in /home/yonatony/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/ClassLoader.php on line 104

Notice: Use of undefined constant DIR - assumed 'DIR' in /home/yonatony/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/ClassLoader.php on line 105

Notice: Use of undefined constant DIR - assumed 'DIR' in /home/yonatony/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/ClassLoader.php on line 104

Notice: Use of undefined constant DIR - assumed 'DIR' in /home/yonatony/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/ClassLoader.php on line 105

Fatal error: Class 'CRM_Core_Config' not found in /home/yonatony/public_html/wp-content/plugins/civicrm/civicrm/install/index.php on line 138

  • Please update your task with CiviCRM version and wordpress version you are trying to install on. That helps understanding the issue more. – Hassan Farooq Jan 18 '18 at 19:46
0

Please make sure all files of civicrm were uploaded in your site files and file wp-content/plugins/civicrm/civicrm/CRM/Core/Config.php is present there.

Also make sure your database credentials are correct and following lines are present in the end of file civicrm.settings.php

require_once 'CRM/Core/ClassLoader.php'; CRM_Core_ClassLoader::singleton()->register();

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.