1

enter image description here

is there any alternative? that I can use to install Drupal+CiviCRM development environment. taking too long it(in screenshot) took 2 hours.

1

You might try a CiviBuild in Docker. See https://github.com/michaelmcandrew/civicrm-buildkit-docker for the link and how to install it.

  • Thanks, but my problem has been solved and I have switched to Linux(Ubuntu); it might help others... – Riajul Feb 1 '18 at 15:09
0

I use FTP and upload all the files and then run the installer.

https://www.drupal.org/docs/7/installing-drupal-7/step-1-download-and-extract-drupal

I do the same with CiviCRM

https://docs.civicrm.org/sysadmin/en/latest/install/drupal7/

  • Actually, i'm trying to create Entity using command line and generating sql for them as said here: docs.civicrm.org/dev/en/latest/extensions/civix/… command i need to run is: <civiroot>/bin/setup.sh -g to generate sql – Riajul Jan 23 '18 at 10:56
  • The page says: Caution This functionality is considered "experimental and incomplete". – Jenni Simonis Jan 23 '18 at 11:03
  • How you create proper working Entity? can you give me some instruction or any tutorial? – Riajul Jan 23 '18 at 18:20
0

Thanks my Problem has been solved! I have used this technique to solve this Problem:

I wanted to use ./bin/setup.sh -g this command to generate sql and DAO, for that what I did is:

Just downloaded civicrm-core from GitHub and then patched with an installation of CiviCRM drupal module.

How I did patch this: (in Ubuntu)

I have just mixed/merged civicrm-core and CiviCRM's drupal module in one directory.

and then I have just configured civicrm-core/bin/setup.conf by copying setup.conf.txt with my real installation of CiviCRM database information.

that's it configuration success.

now I can use ./bin/setup.sh -g while i am on civicrm-core-master directory.

to generate sql and DAO please read carefully carefully every step from here: https://docs.civicrm.org/dev/en/latest/extensions/civix/#generate-entity

If you are having any difficulties please comment down below, I will be glad to help you.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.