1

I've just updated a Joomla 2.5.28 site from an older version of CiviCRM (4.4) to the latest 4.7.29. Now I can't edit any of the fields under the "Contact Details" pane for existing records.

There are two errors:

  1. When editing these fields for contacts that have custom subtypes, a popup appears saying "One or more contact subtypes have been de-selected from the list for this contact. Any custom data associated with de-selected subtype will be removed as long as the contact does not have a contact subtype still selected. Click OK to proceed, or Cancel to review your changes before saving."

  2. For all contacts (including custom subtypes from item 1 above), saving doesn't work and throws this error: "Custom Addressee is a required field if Addressee is of type Customized."

It's also interesting that I can create NEW records of contact subtypes, but get the errors again if I try to update the Contact Details of the new record.

I found this post (Why after importing contact records were Addressee field values set to "Customized" for records where Custom Addressee had a null value?) which seems to address issue #1, but I'm a bit stumped as to issue #2. And I didn't want to try the correction suggested in this post until I knew if the two issues could be related.

Site details: Joomla 2.5.28 CiviCRM 4.7.29

  • Crap. Just noticed I made a mistake in my first post -- the last paragraph should say that the post addresses item #2, and #1 has me stumped :-) – minbori Jan 24 '18 at 14:14
2

I feel this issue is documented and fixed at CRM-21180. You can try by applying patch or wait for 4.7.30 release.

  • Thanks for the answer, Pradeep. Yes that seems to address issue #2, but not issue #1? – minbori Jan 25 '18 at 13:27
  • I feel it does please try – Pradeep Nayak Jan 25 '18 at 13:28
  • Oh ok, will do so. – minbori Jan 25 '18 at 13:31
  • I'm not having much success. I'll admit I'm not sure exactly what procedure I need to follow to apply the patch :-/ I've tried updating just the 11 files in the patch, and I've tried updating the whole codebase. Both break my 4.7.29 installation. Are there any guides you could point me to? – minbori Jan 26 '18 at 11:53
  • Ooops, I should have searched first, then posted after :-) civicrm.stackexchange.com/questions/4622/… – minbori Jan 26 '18 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.