1

I am trying to upgrade from 4.7.18 to 4.7.29. I am doing this on a development server and I have created a sub-domain for it and made sure that the site is running before I attempt to do the upgrade.

I have tried the upgrade several times (having restored the database and reset paths) and I still get stuck at the begging saying - [Executed: Begin Upgrade to 4.7.19].

The url I am at is https://[subdomain].[domain.org]//civicrm/upgrade/queue/runner?reset=1&qrid=CRM_Upgrade

I have PHP 7.0.22 on my test server and MySQL 5.7.21. Basically, what comes out the box with an Amazon Ubuntu AMI.

Thanks, Josh

  • What is in the civicrm log file? Some schema changes take a while depending on your table sizes and the log may show more detail than the UI. – Aidan Jan 30 '18 at 9:01
1

I used drush civicrm-upgrade-db and it appears to be working perfectly.

I had already put the 4.7.29 files in /sites/all/modules/civicrm so only the database had to be upgraded.

-Josh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.