2

I am getting the error "Incorrect Resource URL" and seeing 404 for URLs that go to "undefinedjs/jquery/jquery.crmAjaxTable.js" and many instances of the error "Unable to reach the server. Please refresh this page in your browser and try again."

I have tried resetting the URL (/admin/setting/updateConfigBackend?reset=1), adding a static path (civicrm/admin/setting/url?reset=1) and doing an override (https://docs.civicrm.org/sysadmin/en/latest/customize/settings/).

I am seeing the error in the UI and viewing the 404 using the browser console. I am also using the CV command from the command line and see that the generated path from (/admin/setting/updateConfigBackend?reset=1) does not match what I would expect.

[root@domain default]# cv path -c userFrameworkResourceURL https://crm.domian.org//home/user/public_html/sites/all/modules/civicrm

I think the URL should be https://crm.domian.org/sites/all/modules/civicrm.

This started when upgrading a Drupal 7 site to 4.7.28.

Help with this is greatly appreciated. I am out of ideas.

Thanks!

  • I had a similar strange problem, and it had to do with symbolic links in unix. Q & A in civicrm.stackexchange.com/questions/21814/… . – Kainuk - CiviCooP Feb 6 '18 at 19:10
  • I tried this and it sounds like it would be the answer but it is not working the way I am understanding it. I am seeing no change just adding this line to the CiviCRM settings file. Is there a specific place this should be added. Is there a variable that needs to be initialized? – Josh Feb 12 '18 at 8:17
  • Sorry this went in two comments but with this variable defied I get no results for cv path -d '[civicrm.root]' or cv path -d '[cms.root]'. Thanks, Josh! – Josh Feb 12 '18 at 8:17
2

We've had basic authentication active on the installation which broke the check. After adding the server IP to the whitelist the error disappeared.

1

Just fixed this on my site by setting allow_url_fopen to "on" in php settings.

1

I had this issue, which came down to the l10n.js file not being created correctly. To troubleshoot this, I:

  • Opened my browser's Developer Tools (by pressing F12);
  • Went to the "Network" tab and filtered by "JS";
  • Found the file that had my current language in the name (see screenshot - in this case, "en_US").
  • Right-clicked the name and selected "Open in New Tab".

I saw an error message, which I was able to troubleshoot more directly.

For folks upgrading to Civi 5.3.x using multilingual, you're likely to encounter the same problem. The trick is to rebuild the multilingual schema. I did this with drush cvapi system.rebuildmultilingualschema, comparable commands exist for WordPress etc.

I figured this out because my images weren't loading, which I saw used the value CRM.config.resourceBase which this forum post told me was set in the l10njs/<language> file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.