1

When I go to Configuration >> System Settings & URL >> Clear Cache and Update Paths https://www.example.com/civicm/admin/setting/updateConfigBackend?reset=1 I tried to reset path and I get a WSOD with the following error

Fatal error: require_once(): Failed opening required
 'CRM/Core/Payment/SDD.php'
 (include_path='.:/home/hob/www/lyme/sites/all/modules/contrib/civicrm:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/packages:.:/home/hob/www/lyme/sites/all/modules/contrib/civicrm:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/packages:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/vendor/tecnickcom:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/vendor/phpseclib/phpseclib/phpseclib:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/vendor/pear/pear_exception:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/vendor/pear/auth_sasl:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/vendor/pear/net_socket:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/vendor/pear/net_smtp:/home/hob/www/lyme/sites/all/modules/contrib/civicrm/vendor/pear/validate_finance_creditcard:.:/usr/local/php56/lib/php')
 in
 /home/hob/www/lyme/sites/all/modules/contrib/civicrm/Civi/Payment/System.php
 on line 59

I see a similar error listed out here : CiviCRM 4.7.8 error after upgrade on eWay Recurring

Also when I checked the database for civicrm_setting table, I found all the values to be null.

enter image description here

When I looked into CRM/Core/Payment/ folder, I did not find SDD.php is that an issue?

I went to the database and set all the payment processor.is_active = 0 . I go back and Reset Paths and I get list of errors which are as given below enter image description here

and last error on this list is this

Error loading module file (). Please restore the file or disable the module.
  • Did you change the extension path? – Pradeep Nayak Feb 8 '18 at 3:49
  • @PradeepNayak, currently extension path is at sites/all/modules/civicrm_extensions ? should I check it in the database? I have not changed it though – harshal Feb 8 '18 at 3:52
2

If you have performed path reset than path of extension must have been updated and the system already have SDD payment processor created therefore it is throwing file not found error.

You can fix this in either of 3 ways:

  1. If you have db access then update civicrm_payment_processor.is_active = 0 for SDD payment processor type and then update the extension directory path by navigating to Administer >> System Settings >> Directories

  2. Update the extension directory path in civicrm_setting table where name = extensionsDir (make sure you serialize the data correctly)

  3. Over-ride the extension directory path in civicrm.settings.php

    $civicrm_setting['Directory Preferences']['extensionsDir'] = 'xxx/sites/default/files/civicrm/persist/contribute/';

and then update the directory path by navigating to Administer >> System Settings >> Directories

HTH

Pradeep

  • I tried #1 and I get some errors after resetting path . Should I restore to older backup where I did not do reset path which led me to Fatal Error: (the first error listed in title) and then try the #1 ? – harshal Feb 8 '18 at 4:18
  • Please update the extension path in Directories and Resource URL and then visit Extension page and click refresh and also clear CiviCRM cache(make sure you don't click on Reset Path button). – Pradeep Nayak Feb 8 '18 at 4:19
  • I followed the above steps 1) Updated the Extension path in Directories and Resource URL 2) Clicked Refresh on the Extension Page 3) Cleared the civicrm cache but it still gives Unknown extension error – harshal Feb 8 '18 at 4:34
  • Hi @Pradeep, it worked finally, I had missed something probably when I did #1,#2 and #3 mentioned in the previous comment, thanks for your valuable inputs and time!!! – harshal Feb 8 '18 at 4:49
  • Check for folder permission and also check if all the active extension are present under the extension directory – Pradeep Nayak Feb 8 '18 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.