0

After Upgrading to PHP 7.0 - I keep getting the following error on the Member Dashboard. Do you know what causes this? This happened to be before - I changed the resource URLs to Absolute and that fixed it - now this error is back.

`Warning: get_headers(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/sitename/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check/Component/Env.php on line 903

Warning: get_headers(): This function may only be used against URLs in /home/sitename/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check/Component/Env.php on line 903`

I should also note that the System Status Page mentions that the "The Resource URL is not set correctly." even though it is.

Update: Thanks to Yurg's answer below - I contacted the webhost - they store PHP options elsewhere - I was able to change settings to allow_url_fopen=1 and that fixed everything!

1

Perhaps allow_url_fopen=1 should be set in PHP.ini file on your web host.

  • Its enabled by default on the server - but I added to PHP,ini anyways. Issue still persists. Luckily error only shows up as Admin. – themak Feb 13 '18 at 16:41
  • Actually - my host stored the settings elsewhere - I was able to change the settings to allow_url_fopen=1 - Thank you! – themak Feb 13 '18 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.