I recently installed CiviCRM 4.6.2 in our multisite Drupal 7 environment, running on IIS 8. I have CiviCRM 4.3.2 running on a Drupal 6 base without any issues on the same server; my plan is to migrate the D6 install and most of the data (contacts, etc) to D7.

Installation and configuration of CiviCRM went fine, as did importing contacts. However, I'm currently stuck on an issue that appears to have something to do with AngularJS and Windows/IIS paths, though I can't say that for sure.

When I go to Mailings -> New Mailing, it hangs - all it says on the page is "Initializing..." In Chrome's console, I see this error:

TypeError: a.headers is not a function
  at n (angular.js:9720)
  at angular.js:13248
  at n.$get.n.$eval (angular.js:14466)
  at n.$get.n.$digest (angular.js:14282)
  at n.$get.n.$apply (angular.js:14571)
  at l (angular.js:9698)
  at M (angular.js:9888)
  at XMLHttpRequest.F.onload (angular.js:9829)

In Drupal's watchdog log, I get this error (identifying path info changed):

LOCATION    https://www.fake.com/civicrm/ajax/angular-modules?l=en_US&r=fE7WM

REFERRER    https://www.fake.com/civicrm/a/

MESSAGE     Warning: file_get_contents(E:\webroot\drupalroot\sites\all\modules\civicrm/ang/crmMailingAB/E:\webroot\drupalroot\sites\all\modules\civicrm/ang/crmMailingAB\EditCtrl/report.html): failed to open stream: Invalid argument in Civi\Angular\Manager->getPartials() (line 203 of E:\webroot\drupalroot\sites\all\modules\civicrm\Civi\Angular\Manager.php).

It definitely looks to me like AngularJS is getting confused by Windows paths, but I'm not 100% sure that that's what's going on, nor how to fix it if I'm right.

2 Answers 2


As discussed in CRM-16499, the bug involves processing file relative-paths and absolute-paths on Windows. I reproduced the bug with D7 and XAMPP for Windows. There's a pending fix (.patch).

It might get merged before tomorrow's release (4.6.3); otherwise, it'll go out with 4.6.4.

Note: For general advice on how to interpret/evaluate pending patches, see http://wiki.civicrm.org/confluence/display/CRM/Verify+a+patch


Looks like you've found a bug.

It's currently being worked on by the core team, you can follow progress at


  • Patch appears to have worked.
    – pmoz
    Jun 2, 2015 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.