2

Although, I had orignally thought the issue was on the "Webform CiviCRM Integration" module end, further testing shows it is likely an issue on the CiviCRM end since when I manually try to create the relationship I end up with a "spinning wheel" and a page refresh gives the following error:

"unknown relationship create error API (EntitySetting, get) does not exist (join the API team and implement it!)"

Any insight?

  • have you created any Relationships between Contact Sub-types then perhaps deleted the Contact sub-type? – petednz - fuzion Feb 25 '18 at 19:32
  • No, there has been no changes in regards to Contact Sub-types – Thinkwell Feb 26 '18 at 1:31
  • Solved - After more testing, I have discovered the issue is with the CiviCRM extension "Related Permissions Module (nz.co.fuzion.relatedpermissions)". Once disabled, the ability to add relationships between two contacts resumed. – Thinkwell Feb 26 '18 at 15:58
  • I would be interested to know how to replicate this. That extension - one of ours - is in use on a lot of sites running v complex configurations. Was it the latest version? – petednz - fuzion Feb 26 '18 at 20:09
  • Hi Peter, would be happy to provide any info you require but can tell you I tested yesterday with a fresh install of Drupal 7.57, CiviCRM 4.7.30 and Related Permissions Module 1.3 . – Thinkwell Feb 27 '18 at 14:58
2

Ensure you have extension nz.co.fuzion.entitysetting enabled as it is a requirement of nz.co.fuzion.relatedpermission

  • Perfect. That was an issue that occurred. I had nz.co.fuzion.entitysetting and the issue is gone. – Ichi Aug 12 '18 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.