1

In Wordpress, it is possible to insert CiviCRM shortcodes for, eg, profiles, directly in the Page/Post editor.

However, when I do this, the 'Insert CiviCRM content' screen displays, but there is no visible button available to insert the code and return to the Wordpress editor.

See screenshot of what I see.

Is this a bug, or is something else preventing the button from appearing? enter image description here

2

Probably a typical WP plugin/theme conflict. Try to disable all your plugins except CiviRM and see if you can see the button. If you can see it, then turn them on in small groups, once you find a group, then do those one-by-one to narrow down which one is causing the problem. If you still cannot see it, turn all your plugins back on and change your theme to one of the WP twenty-themes and see if you can see it.

If it is the theme, you can make your shortcode edits and then switch back to the theme you normally use.

  • Just tested, and unfortunately in this case this has not worked. I disabled all plugins, cleared all caches (browser and CiviCRM) and there are still no buttons visible. – fred2 Mar 1 '18 at 20:44
  • 1
    Did you try the theme change? – Iowa Boy Mar 1 '18 at 21:27
  • Just tried it now using a standard Wordpress theme. Still no luck. – fred2 Mar 2 '18 at 2:07
  • Do an inspect and look for JS errors in the console. Open your url in Chrome. Right click > Inspect Look for the tab labeled Console. Do you have any JS errors listed here? – Iowa Boy Mar 2 '18 at 16:50
  • I thought I'd fixed this, but it turns out I was seeing separate bug which hid a different button. The original bug which is hiding the shortcode button is still unresolved. – fred2 Mar 4 '18 at 20:55
0

I have same problem and my solution is deactivate all plugins. After that turn one by one plugin on. I investigate that my plugin ALO EasyMail Newsletter cause CiviCRM shortcode error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.