3

We are on Civi 4.7.29 and Wordpress 4.9.4

Today I noticed about 20 transactions with the status Pending Incomplete. They are all intended to be recurring. I found out that we are getting notifications from Paypal on everyone of these transactions and some of these people confirmed the payment was a success on their end. But it is not updating their memberships in Civi and it is not sending them a receipt from civi or recording it as a completed contribution.

Does anyone know where I should start with resolving this? I did find several other posts related to this issue, but I did not see an answer with any of them.

We confirmed that payments go through properly with no issues, if it's a single/non-recurring payment.

thank you

***Edit****

I just noticed that when trying to make a recurring payment with my credit card instead of paypal I get this error message

DPRP is disabled. DPRP is disabled for this merchant.

  • The first thing which comes to my mind is that probably an error or so happens when Paypal sends an update to CiVICRM on the payment status. So I would probably have a look at the log files and see if you can detect such a thing. – Jaap Jansma - CiviCooP Mar 6 '18 at 9:36
  • Thank you. I am checking the logs under ConfigandLogs I am not seeing anything that seem to be related to recurring payments. – fdarn Mar 6 '18 at 15:07
3
+50

Apparently Paypal charges extra for recurring functionality and you have not subscribed to the additional $30/mo DPRP service.

DPRP is disabled. DPRP is disabled for this merchant.

https://www.paypal-community.com/t5/About-Business-Archive/quot-DPRP-is-disabled-for-this-merchant-quot-plz-help/m-p/991717#M14689

In your bounty comment you state:

I am looking for a solution that will allow us to accept recurring payments through Civi.

In this case I would recommend you look into Stripe.com which provides these options without charging monthly fees. There is a CiviCRM-Stripe payment extension in active use and development.

1

We had a similar problem with Civi on Joomla which was resolved by updating to 4.7.30.

  • Thank you. Is this problem a known bug in 4.7.29? – fdarn Mar 8 '18 at 12:27
  • I just upgraded to 4.7.31 and tried a test transaction. The exact same issue occurred. – fdarn Mar 8 '18 at 16:29
  • Did you solve in 4.7.30? – Andy Goodall Apr 7 '18 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.