1

Noticed this on a couple of sites - not sure if this is a bug yet. When I tested on dmaster it fills correctly so perhaps this is a bug/regression that has been fixed between 4.7.27 and 4.7.30/31

1

This is a CiviCRM Core bug, reported here: https://lab.civicrm.org/dev/core/issues/173

It applies to pay later contributions when the email address is included in the profile.

0

I see this too. I believe its only when the pay later is enabled and the donor selects pay later. The email addresss is not shown. A simple hack may be to find the code change it to just "has been sent." until someone with more knowledge than me can fix the problem. I tried it with a 4.6.X version (on Joomla) and the email showed properly. I tried it with a 4.7.X (on Wordpress, I forget which version I was at! 32?) and had the problem. So I upgraded that to 5.0.2 and still have the problem.

  • Thansk for commenting. My testing on Sandbox is that it shows the email address for Pay Later too. "An email confirmation with these payment instructions has been sent to demo@example.com." So am going to ignore and assume it has been fixed as a bug already. – petednz - fuzion May 1 '18 at 23:35
  • one of us may have to test on the 5.1 release tomorrow – petednz - fuzion May 1 '18 at 23:36
  • I can confirm this problem with CiviCRM 4.7.27 + Drupal 7. Upgrading to CiviCRM 5.2 does not resolve the issue, so I believe this is still a bug. It would seem there are additional conditions for the problem - I suspect it might be only showing up when an email is included in the profile. – Alan Dixon Jun 8 '18 at 16:58
  • And I can also confirm it doesn't show up when I disable the email in the profile. – Alan Dixon Jun 8 '18 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.