1

I use a separate email editor to code emails before copying and pasting into civicrm to send.

I have noticed that if I copy and paste into source and press send without looking at it in the wysiwyg editor the code works as expected.

If I look at it first the following code is stripped out. I am not a proficient email coder - this is what the programme I use puts in.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional //EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office"><head>

The editor is CKeditor. Can I stop it doing this? I have a work around but if I could stop it (or understand if there's a good reason why it is doing it) that would be better!

Thanks Caroline

New information: I think part of the answer is here. How do I override the default CKEditor configuration? If that's right I'm not still not sure what I need to do! If anyone can help that woudl be great :)

3
  • You say "the following code is stripped out" - but i don't see the code pasted. Can you add some examples, and perhaps explain what programme you are copying this from.
    – petednz - fuzion
    Mar 11, 2018 at 19:45
  • 1
    Hello - sorry I realised after your comment that I hadn't formatted my post correctly. I have also managed to get this to work (I think) by goign to admin console, display preferences, configure wysiwyg editor, email, and adding fullpage = true. I'm reluctant to post this is as a correct answer - but it seems to work for me! Thank you for replying!
    – Caroline B
    Mar 12, 2018 at 21:06
  • I think any answer that works deserves posting as an Answer ;-)
    – petednz - fuzion
    Mar 12, 2018 at 23:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.