1

When I tried installing by uploading the package file, nothing happened. Then I tried exactly as the installation guide says for Joomla and I get this error: Please enter a package folder. Unable to find install package

This is a new Joomla installation 3.8.5, I am trying to install CiviCRM 4.7.31. I have PHP 5.6. I'm hosted on a shared server so not sure how to check the PHP extensions and configuration or the MySQL version with my cPanel.

I have never used CiviCRM before but I have been using Joomla for years and never got that error with any installation packages.

I would love some help and am looking forward to your support.

  • If you want, please contact me throught the contact form from vicaroh.com and send me the url/path to the site , in order to check if it is ok... Another trouble can be the memory limit, docs.civicrm.org/sysadmin/en/latest/requirements please, check it, and pleased to keep informed! Francesc – Francesc Mar 19 '18 at 13:02
2

First of all, my apologizes for my english, it is not very fluent. Now, my answer: Have you checked if this version of CiviCRM is compatible with your host PHP version? CiviCRM package is not an Autoinstaller Package as many other extensions: components or plugins. I think the process to install is: -Upload the compressed CIVICRM package (Check than is a Joomla version) to the 'tmp' folder of your Joomnla installation. Uncompress-Expand it.

-Now, in your tmp folder there must contains a folder 'com_civicrm/ In administrator/extensions/install-uninstall/install from directory add the /com_civicrm/ subfolder at the end and click install. If everything goes right you will get a 'component successfully installed'.

The link to Civicrm help : https://docs.civicrm.org/sysadmin/en/latest/install/joomla/

Good Luck! Francesc

  • Hi Francesc, Thanks for your answer, I actually checked everything and as described in my post, I did the extact procedure described in the CiviCRM joomla installation help. And it didn't work. That's why I asked for help. I really don't see why it wouldn't work and need some more help. Thank you for your further support. – Joanie Waelti Mar 15 '18 at 9:11
1

in order to check/know what versions of php, SQL engine, etc. you can see it at Joomla BAckend, System, System information (last menu item). You will get information about many parameters. Have you checked by FTP if the uncompressed folder of com_civicrm exists before going on the installation step via joomla installer?. If you clean the Caché, the system deletes the contentsd from the folder /tmp/ Also, maybe the hosting have any limitations? Have you tried to install in local?(For example with Xammp-bitnamy) Francesc

  • Hello and thanks for keeping with me. php version: 5.6.32. Yes FTP is fine and the folder is uncompressed and located exactly where it is supposed to be. I have not cleared the cache since and my hosting doesn't have limitations, I have a huge pack. I don't install anything in local though. I don't know how this works and have never done it before, I usually have a sandbox DB for tests and the live site. I'm using a brand new sandbox now for this test. – Joanie Waelti Mar 19 '18 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.