1

We are unable to get authorize.net talking back to CiviCRM in regards to recurring payments.

In talking with authorize.net folks and they pointed out that query strings are not allowed to be used in the Silent Post URL: https://support.authorize.net/s/article/Why-Are-My-SIM-Relay-Response-Transactions-Timing-out-After-Submitting-the-Request

query string dissallowed

However, CiviCRM docs say for Wordpress you need to use a query string? https://docs.civicrm.org/sysadmin/en/latest/setup/payment-processors/authorize-net/ WP silent post URL We've checked the logs and see that authorize.net is not communicating back to CiviCRM. The transaction ID's for recurring payments are missing.

So who is right here and are people successfully using WP and Civi with authorize.net?

We have checked that are servers support connections via TLS 1.2.

On WP 4.9.4 and Civi 4.7.30

  • 1
    The documentation says http for the silent post url. Would that make a difference? I would expect that that should be a secure URL instead ... – Andy Burns Mar 13 '18 at 16:24
2

The culprit was the iThemes Security plugin. Here are the settings you should disable to avoid getting a 403 forbidden error that prevented the IPN from registering.

Under Banned Users

  • Hack Repair Default Blacklist

Under System Tweaks

  • Suspicious Query Strings
  • Long URLs

I also enabled Enable XML-RPC under Wordpress Tweaks. I had encountered failed IPN's from PayPal before so I assume this would be wise to enable as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.