3

Only since upgrading CiviCRM to 4.7.29 from 4.7.11 (on Drupal), one of my users with 'editor' role is unable to run a financial report. The error she sees is:

"API permission check failed for FinancialAccount/get call; 
insufficient permission: require administer CiviCRM" 

I can't believe she should need full admin rights just to run this report. On 4.7.11 it wasn't necessary.

Is there a recommended way to investigate the error and see whether assigning a lesser permission to the 'editor' role would restore normal service? The upgrade process warned of a new permission 'manage tags' but nothing to do with Financial Accounts or CiviContribute.

1
  • Same here on a CiviCRM 5.3.1. Have you found a solution for this? Commented Nov 26, 2018 at 23:25

1 Answer 1

1

This bug has been reported at Bookkeeping Transactions Report insufficient permissions and from CiviCRM 5.9 will be fixed. Here the affected code.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.