1

Hi We have a situation where we would need one member to be a part of many organizations.

So when a Joomla user login to their account for the first time and apply for an membership on behalf of an organization it works fine.

However if the user select Enter a new organization when they want to register another organization and submit the form No new account will be created instead the existing organization gets updated even though they are different organization names.

I have tried by disabling the membership section just to see if the issue when creating the relationship but it doesn't do any changes. Has anyone experienced this before ?

Any advice would be highly appriciated

enter image description here

  • Can you clarify what your Matching Rule is for Organisation + Unsupervised? otherwise it sounds like a bug and if you can replicate on a demo site then it can be added to the bug list – petednz - fuzion Mar 15 '18 at 20:41
  • Thanks for your reply. I have changed the organisation unsupervised rule to name only . but still the same i will try and do this on a demo site – Gayan Rodrigo Mar 16 '18 at 9:58
  • Unfortunately i cant reproduce this in the demo site as it doesn't allow creating user accounts in Joomla. – Gayan Rodrigo Mar 16 '18 at 10:47
  • @petednz-fuzion Here is a fresh installation i made just for this purpose jomlify.vanlookup.com/ username : jane / Password : 123456 admin login : guest /123456. You could first try to login as jane and click on new organization from top menu and then submit a new organization and you will see the result once you login as the admin using the account name guest – Gayan Rodrigo Mar 19 '18 at 17:16
  • Hi Gayan. see my answer below. took about an hour to run around all this to prove it. Another time it is always worth comparing with Demo sites. There was no need to 'create a new user' as you could have tested this purely as admin (which is what I did) – petednz - fuzion Mar 19 '18 at 20:45
1

This appears to be a bug and you should report it in GitLab.

Steps to replicate.

Set up Contribution page using 'on behalf of'

Submit the form a first time, create your 'on behalf of' Org

Submit the form a second time for New Org, using new name/email.

Outcome the original Org now has the new email but the old name. Both contributions are on their record.

Testing was done via http://dmaster.demo.civicrm.org/civicrm/contribute/transact?reset=1&id=4 (which will soon disappear)

Update - There is now a patch submitted and an issue filed in GitLab - https://lab.civicrm.org/dev/core/issues/26

  • Thanks for your explanation. I thought the same but didnt know how to report it. I will report now – Gayan Rodrigo Mar 19 '18 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.