1

I could really use some guidance on how to troubleshoot this. This morning, we sent an email out to about 100 addresses using CiviMail and it worked fine.

Now, we can't. We didn't make any changes in the meantime. I can't send a test email, and when we schedule a job and the cron runs, CiviCRM shows it as successful, but no one is receiving emails.

When I log the mail to a file, we can see it going there, it's just not getting sent out. Other mail from contacts or the test mail() function still works.

I've checked the logs and can't see anything. Our hosting provider is not being helpful right now, and I could use some other guidance on information I can provide them to help troubleshoot. I could also use some suggestions on where to look in Civic.

I know everyone says "it used to work". Honestly, it really did.

We are using 4.7.15 with wordpress.

  • This is very strange. Are you sure you did not change a setting or something in the meantime? If not it sounds to me that your hosting has a limit on the amount of emails you could sent. It would also be helpfull if you post an excerpt from the log file. – Jaap Jansma - CiviCooP Mar 28 '18 at 11:36
  • I think we have the same kind of problem. Nothing in Drupal error logs, nothing in CiviCRM error logs, even after enabling debugging. Have disabled all customisations and extensions (and custom modules), still CiviMail fails (although it says it has completed the mailing). The hosting provider say nothing is being sent from CiviCRM, except the Send emails (from the action menu) which still work, and the Test Outbound mail setting page. Anyone else? – Jon-man Apr 6 '18 at 22:27
  • Is there anything in the httpd/apache error logs? – Demerit Apr 10 '18 at 0:45
  • Sadly not. Nothing in Drupal logs, CiviCRM logs, Apache logs – Jon-man Apr 11 '18 at 18:45
  • @Jane Do the emails show as sent/delivered in the CiviMail report, and do they show up on the contacts' activities? – Laryn - CEDC.org Apr 12 '18 at 16:39
1

I had exactly the same problem.. emails going out fine for months then BAM! nothing other than an error. I fixed it by updating our SparkPost API Key.

  • This is a good answer if the OP used SparkPost. if they didn't you may want to open a new Q and do your own Answer and tag it with sparkpost – petednz - fuzion Apr 3 '18 at 22:51
  • 1
    I have tried Sparkpost also, and the same outcome. It won't send any CiviMail (bulk mailing) – Jon-man Apr 6 '18 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.