4

Everytime I try to make an event, or access any page with event information, I get the following error:

You have requested a non-existent service "civi_flexmailer_required_tokens".

Using latest Civi 5, Wordpress 4.9

4 Answers 4

3

I had this problem after upgrading from Drupal 8 to 9 and upgrading Civi to 5.51.1. Thanks to @seamuslee on Mattermost for solving this issue for me. These are the steps I followed on a Drupal installation to fix it:

  1. Disable Mosaico in Extensions
  2. Disable Flexmailer in Extensions
  3. Delete the Flexmailer extension directory (/sites/default/files/civicrm/ext/org.civicrm.flexmailer)
  4. Clear Civi caches and rebuild paths/menus at /civicrm/admin/setting/updateConfigBackend?reset=1
  5. Enable Flexmailer in Extensions
  6. Enable Mosaico in Extensions

This issue is also answered at CiviCRM core now includes Flexmailer: how to remove old flexmailer extension?

1
6

we have similar issue but after clearing civicrm cache using menu/rebuild it started working.

1
  • For drupal civicrm/menu/rebuild?reset=1 Jun 18, 2018 at 22:53
2

We were seeing the same problem after upgrade to CiviCRM 5.0.2. This is a detail follow-up on Sunil's answer above (sorry, didn't have enough reputation points to comment on his directly and thought this would be useful.)...

The URL to clear the CiviCRM Cache is:

http://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/menu/rebuild&reset=1

0

Still figuring this out - but disabling Event Calendar (com.osseed.eventcalendar) fixed the issue.

Update: Cleaned up Cache - error persisted, Cleaned up cache and rebuilt CiviCRM menu - re-enabled com.oosseed.eventcalendar - all good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.