1

I am using latest Simple Donate on D7 with Civicrm 4.7.29. I get this error when I go to the contribution page configured for Simple Donate:

Warning: implode(): Invalid arguments passed in CRM_SimpleDonate_Page_SimpleDonationPage->browse() (line 71 of /home/lifechallengesem/public_html/data/sites/default/files/civicrm/ext/com.webaccessglobal.simpledonate-2.0/CRM/SimpleDonate/Page/SimpleDonationPage.php).

any help troublshooting would be greatly appreciated!

  • I had an issue with simple donate throwing errors when I didn't have any payment processor setup. So, do you have one setup? – BBuchanan Apr 19 '18 at 2:17
3

Looking at the extension code it seems to me that the Simple Donate pages are not set properly in settings table. Can you please re-save the Simple donate page setting by navigating to Administer >> CiviContribute >> Simple Donate Configuration ?

  • Hmm...not allowing me to save a new configuration. I tried saving a different contribution page and de-slecting the ziptastic function. Tried several different configs. The new configs will not save. – John Richardson Apr 12 '18 at 19:42
  • What error do you get? – Pradeep Nayak Apr 12 '18 at 19:43
  • No error showing in browser. The page just refreshes to "[domain]/civicrm/admin?reset=1". Doesn't give a message about successfully saved. I'll check logs to see what's there... – John Richardson Apr 12 '18 at 19:50
  • Here's what's in the log: Notice: Constant CIVICRM_MEMCACHE_PREFIX already defined in include_once() (line 359 of [domain]/civicrm.settings.php). – John Richardson Apr 12 '18 at 19:53
  • Are you having N sites installed on same instance having CiviCRM enabled? – Pradeep Nayak Apr 12 '18 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.