1

CiviCRM running very slow on local network, but index.php ,phpmyadmin and joomla are fine. What could be the problem? I tried this solution (https://processwire.com/talk/topic/8320-local-dev-server-running-slow-this-may-be-of-help/) to change localhost in conf.php into 127.0.0.1 and restart the server pc. But nothing changed. Plus the civicrm home page took almost 30 min to load the "better UI". Please help

-joomla 3.8.7
-mysql 5.5
-apache 2.4
-phpmyadmin 4.8.0.1
-civicrm 5.0.1
-php 7.1.16

The other problem is I could not save/edit anything on civicrm from another computer on the same network
-but editing/saving anything on joomla and phpmyadmin from other pc is fine
-plus on the server read/write have no problem
-civicrm css wont load on local network, but only works on localhost(server)



enter image description here


I'm really sorry if i made my question confusing, please bear with me.

  • What kind of resources does the server have (memory, processor, etc)? What is being allocated for memory, time for processes to run, etc in your php settings? There are so many things that can cause a slow down, but without more information, it's hard to pinpoint it. – Jenni Simonis Apr 25 '18 at 4:25
  • it's fresh install so there are no data, the system info of server is win 7 home premium, intel i5 2300, 4gb ddr3 ram, and 70% free storage – Jennifer Lee Apr 25 '18 at 4:41
  • What's your info in your PHP settings? That'll tell us things like what your max execution time, memory allotment, etc is for your site. I can tell you that years ago I was running a Drupal+Civi install for testing purposes on my Windows machine and it didn't run anywhere near the speed the exact same site did on our hosted server. – Jenni Simonis Apr 25 '18 at 6:27
  • Thank you so much for your help Jenni, but everything is fine except civicrm, so I only need to look for something in those crm folders and files, thankfully i found the solution! – Jennifer Lee Apr 25 '18 at 9:32
4

And once again I had found out the answer on my own, took a lot of time though... it is in components and administrator's civicrm.setting.php (both php file!) just simply change both localhost (see the photos below) into your server IP
Simple as that (yeah I'm so noob TwT), I wish this can help those who have the same problem like mine, apology for my bad grammar english and stuffs :P

enter image description here enter image description here

  • 1
    Great work, and thanks for posting back on it! This suggests that either your local server doesn't have a local entry for localhost in the hosts file (/etc/hosts on Unixes), or that the DNS configuration (/etc/resolv.conf on Unixes) does not check your local hostfile first. If the system is unable to resolve localhost (or resolving localhost takes a long time), you can expect to run into issues elsewhere as well. Try to address the underlying issue. – Chris Burgess Apr 26 '18 at 4:23
  • 1
    I'm glad to help someone with the same problem as mine, debugging sure takes a lot of time :) and thank you for your tips though – Jennifer Lee Apr 26 '18 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.